ΓλωσσοΜάθεια – Παραδείγματα


ΓλωσσοΜάθεια
Παραδείγματα

! ----------------------------------------------------
! Το πρόγραμμα ζητάει έναν τετραψήφιο αριθμό και
! αποθηκεύει τα ψηφία του σε 4 ανεξάρτητες μεταβλητές.
! ----------------------------------------------------

ΠΡΟΓΡΑΜΜΑ Απομόνωση_ψηφίων_τετραψήφιου_αριθμού

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: x, ψ1, ψ2, ψ3, ψ4, υπόλοιπο

ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΡΑΨΕ 'Δώσε έναν τετραψήφιο αριθμό:'
    ΔΙΑΒΑΣΕ x
    ΑΝ x<1000 Ή x>9999 ΤΟΤΕ
      ΓΡΑΨΕ 'Ο αριθμός αυτός δεν είναι τετραψήφιος'
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ x>=1000 ΚΑΙ x<=9999

  ψ1 <-- x DIV 1000
  υπόλοιπο <-- x MOD 1000
  ψ2 <-- υπόλοιπο DIV 100
  υπόλοιπο <-- υπόλοιπο MOD 100
  ψ3 <-- υπόλοιπο DIV 10
  ψ4 <-- υπόλοιπο MOD 10

  ΓΡΑΨΕ 'Τα ψηφία του είναι:', ψ1, ψ2, ψ3, ψ4

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Απομόνωση_ψηφίων_τετραψήφιου_αριθμού
! ----------------------------------------------------
! Το πρόγραμμα ζητάει 3 πραγματικούς αριθμούς α, β, γ
! και λύνει την εξίσωση αx^2+βx+γ=0
! ----------------------------------------------------

ΠΡΟΓΡΑΜΜΑ Δευτεροβάθμια_εξίσωση

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ, Δ

ΑΡΧΗ

  ΓΡΑΨΕ 'Δώσε το συντελεστή α:'
  ΔΙΑΒΑΣΕ α
  ΓΡΑΨΕ 'Δώσε το συντελεστή β:'
  ΔΙΑΒΑΣΕ β
  ΓΡΑΨΕ 'Δώσε το συντελεστή γ:'
  ΔΙΑΒΑΣΕ γ

  ΑΝ α<>0 ΤΟΤΕ

    Δ <-- β^2-4*α*γ
    ΑΝ Δ<0 ΤΟΤΕ
      ΓΡΑΨΕ 'Η εξίσωση είναι ΑΔΥΝΑΤΗ'
    ΑΛΛΙΩΣ_ΑΝ Δ>0 ΤΟΤΕ
      ΓΡΑΨΕ 'Η εξίσωση έχει ΔΥΟ ΡΙΖΕΣ:'
      ΓΡΑΨΕ 'ρ1 =', (-β+Τ_Ρ(Δ))/(2*α)
      ΓΡΑΨΕ 'ρ2 =', (-β-Τ_Ρ(Δ))/(2*α)
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Η εξίσωση έχει ΜΙΑ ΔΙΠΛΗ ΡΙΖΑ:'
      ΓΡΑΨΕ 'ρ =', -β/(2*α)
    ΤΕΛΟΣ_ΑΝ

  ΑΛΛΙΩΣ

    ΑΝ β<>0 ΤΟΤΕ
      ΓΡΑΨΕ 'Η εξίσωση έχει ΜΙΑ ΡΙΖΑ:'
      ΓΡΑΨΕ 'ρ =', -γ/β
    ΑΛΛΙΩΣ
      ΑΝ γ<>0 ΤΟΤΕ
        ΓΡΑΨΕ 'Η εξίσωση είναι ΑΔΥΝΑΤΗ'
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ 'Η εξίσωση είναι ΑΟΡΙΣΤΗ'
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ

  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Δευτεροβάθμια_εξίσωση
! ----------------------------------------------------
! Το πρόγραμμα ζητάει τιμές για έναν πίνακα Π και μια
! τιμή προς αναζήτηση. Στη συνέχεια εμφανίζει σε ποια
! θέση υπάρχει ή ζητούμενη τιμή (αν υπάρχει).
! ----------------------------------------------------

ΠΡΟΓΡΑΜΜΑ Εύρεση_τιμής_σε_πίνακα

ΣΤΑΘΕΡΕΣ
  Ν=10

ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ: ζητ_τιμή, θέση, Π[Ν], i
  ΛΟΓΙΚΕΣ: βρέθηκε

ΑΡΧΗ

  ΓΙΑ ΑΠΟ ΜΕΧΡΙ Ν
    ΓΡΑΨΕ 'Δώσε την', i, 'η τιμή του πίνακα:'
    ΔΙΑΒΑΣΕ Π[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Δώσε την τιμή που αναζητάς:'
  ΔΙΑΒΑΣΕ ζητ_τιμή

  βρέθηκε <-- ΨΕΥΔΗΣ
  i <-- 1
  ΟΣΟ βρέθηκε=ΨΕΥΔΗΣ ΚΑΙ i<=Ν ΕΠΑΝΑΛΑΒΕ
    ΑΝ Π[i]=ζητ_τιμή ΤΟΤΕ
      βρέθηκε <-- ΑΛΗΘΗΣ
      θέση <-- i
    ΑΛΛΙΩΣ
      i <-- i+1
    ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΑΝ βρέθηκε=ΑΛΗΘΗΣ ΤΟΤΕ
    ΓΡΑΨΕ 'Η τιμή', ζητ_τιμή, 'βρέθηκε στη θέση', θέση
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Η τιμή', ζητ_τιμή, 'δε βρέθηκε στον πίνακα'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Εύρεση_τιμής_σε_πίνακα
< Προηγούμενο: Φωτογραφίες
ΓλωσσοΜάθεια – Παραδείγματα
Επόμενο: Λήψη >