Τώρα είναι Δευτ 29 Νοέμ 2021 09:11 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 25 Σεπ 2021 03:46 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 14 Μαρ 2003 06:19 pm
Δημοσιεύσεις: 14
Syntax: [ Download ] [ Hide ]
! Να γραφτεί πρόγραμμα το οποίο να υπολογίζει και στη συνέχεια να
! εκτυπώνει τις λύσεις της εξίσωσης δευτέρου βαθμού αχ² + βχ + γ.
! Δεδομένα για έλεγχο:
!---------------------
! Αν εισάγουμε α=1, β=1, γ=-2, το αποτέλεσμα είναι χ1=1, χ2=-2.
! Αν εισάγουμε α=1, β=2, γ=1, το αποτέλεσμα είναι μία διπλή ρίζα χ=-1.
! Αν εισάγουμε α=1, β=2, γ=3, η εξίσωση δεν έχει λύσεις στο σύνολο των
! πραγματικών αριθμών
! Αν εισάγουμε α=0, β=3, γ=6, το αποτέλεσμα είναι χ=-2.
! Αν εισάγουμε α=0, β=0, γ=6, η εξίσωση είναι αδύνατη.
! Αν εισάγουμε α=0, β=0, γ=0, η εξίσωση είναι αόριστη.
!======================================================================
! panos giannakopoulos, panosgn@yahoo.com
!======================================================================
ΠΡΟΓΡΑΜΜΑ τριώνυμο
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ, χ, Δ, χ1, χ2
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε τα α, β ,γ:'                        
  ΔΙΑΒΑΣΕ α, β, γ
  ΑΝ α = 0 ΤΟΤΕ ! α = 0, βχ + γ = 0
    ΑΝ β = 0 ΤΟΤΕ
      ΑΝ γ <> 0 ΤΟΤΕ
        ΓΡΑΨΕ 'Η εξίσωση είναι αδύνατη'
      ΑΛΛΙΩΣ ! γ = Ο
        ΓΡΑΨΕ 'Η εξίσωση είναι αόριστη'                                              
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ ! β <> Ο
      χ <-- (-1)* γ/ β
      ΓΡΑΨΕ 'Η εξίσωση έχει μοναδική λύση τη ', χ
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    Δ <-- β^2 - 4* α* γ
    ΑΝ Δ > 0 ΤΟΤΕ
      χ1 <-- (-β + Τ_Ρ(Δ))/(2*α)
      χ2 <-- (-β - Τ_Ρ(Δ))/(2*α)
      ΓΡΑΨΕ 'Δύο ρίζες ', χ1, χ2
    ΑΛΛΙΩΣ_ΑΝ Δ = 0 ΤΟΤΕ
      χ <-- ((-1)* β)/(2* α)
      ΓΡΑΨΕ 'Η εξίσωση έχει διπλή ρίζα', χ
    ΑΛΛΙΩΣ ! Δ < 0
      ΓΡΑΨΕ 'Η εξίσωση δεν έχει λύσεις στο σύνολο των πραγματικών αριθμών'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
Απάντηση με παράθεση  
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές: