Τώρα είναι Δευτ 15 Αύγ 2022 12:18 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΓΡΗΓΟΡΗ ΦΥΣΣΑΛΙΔΑ
ΔημοσίευσηΔημοσιεύτηκε: Τετ 21 Ιαν 2004 04:20 am 
Χωρίς σύνδεση

Εγγραφή: Τετ 21 Ιαν 2004 03:43 am
Δημοσιεύσεις: 3
Syntax: [ Download ] [ Hide ]
!
!=======================================================================
! Το παρακατω πρόγραμμα ειναι μια πιο γρηγορη ταξινομηση με την μεθοδο
! της φυσσαλιδας ετσι ωστε αν σε καποιο ενδιαμεσο βήμα ο πινακας
! ταξινομηθει τότε να σταματουν οι συγκρισεις
!
!=======================================================================
ΠΡΟΓΡΑΜΜΑ ΓΡΗΓΟΡΗ_ΦΥΣΣΑΛΙΔΑ
ΣΤΑΘΕΡΕΣ
  N=10
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: A[N],TEMP
  ΑΚΕΡΑΙΕΣ: I,J
  ΛΟΓΙΚΕΣ: F



ΑΡΧΗ
  ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ N
    ΔΙΑΒΑΣΕ A[I]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  F <-- ΨΕΥΔΗΣ
  I <-- 2
  ΟΣΟ (I<=N) ΚΑΙ (F=ΨΕΥΔΗΣ) ΕΠΑΝΑΛΑΒΕ
    F <-- ΑΛΗΘΗΣ
    ΓΙΑ J ΑΠΟ N ΜΕΧΡΙ I ΜΕ ΒΗΜΑ -1
      ΑΝ A[J]<A[J-1] ΤΟΤΕ
        TEMP <-- A[J]
        A[J] <-- A[J-1]
        A[J-1] <-- TEMP
        F<--ΨΕΥΔΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    I <-- I+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ N
    ΓΡΑΨΕ A[I]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
                                     


Κορυφή
 Προφίλ  
Απάντηση με παράθεση  
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές: