Τώρα είναι Τετ 06 Ιούλ 2022 04:00 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΑΘΛΗΤΕΣ
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 12 Οκτ 2003 11:21 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! _________________________________________________
!
!  Να γραφεί πρόγραμμα το οποίο να δέχεται :
!      -   τα ονόματα
!      - την εθνικότητα και
!      - τους χρόνους
!  οκτώ αθλητών στο δρόμο των εκατό μέτρων και
!    να τους εμφανίζει (χρόνος - όνομα - εθνικότητα)
!  αρχίζοντας από το γρηγορότερο και καταλήγοντας
!  στον πιο αργό αθλητή.
!__________________________________________________
!
!
ΠΡΟΓΡΑΜΜΑ ΑΘΛΗΤΕΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: x , y
  ΠΡΑΓΜΑΤΙΚΕΣ: ΧΡΟΝΟΣ[8] , temp1
  ΧΑΡΑΚΤΗΡΕΣ: ΑΘΛΗΤΗΣ[8,2] , temp2
ΑΡΧΗ

! ΕΙΣΑΓΩΓΗ ΣΤΟΙΧΕΙΩΝ ΣΕ ΔΥΟ ΠΙΝΑΚΕΣ

  ΓΙΑ x ΑΠΟ 1 ΜΕΧΡΙ 8
    ΓΡΑΨΕ 'Δώσε το όνομα του αθλητή της διαδρομής Νο : ', x
    ΔΙΑΒΑΣΕ ΑΘΛΗΤΗΣ[x,1]
    ΓΡΑΨΕ 'Δώσε τη χώρα του αθλητή της διαδρομής Νο : ', x
    ΔΙΑΒΑΣΕ ΑΘΛΗΤΗΣ[x,2]
    ΓΡΑΨΕ 'Δώσε το χρόνο του αθλητή της διαδρομής Νο : ', x
    ΔΙΑΒΑΣΕ ΧΡΟΝΟΣ[x]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ΤΑΞΙΝΟΜΗΣΗ ΦΥΣΣΑΛΙΔΑΣ ΚΑΙ ΤΩΝ ΔΥΟ ΠΙΝΑΚΩΝ

  ΓΙΑ x ΑΠΟ 2 ΜΕΧΡΙ 8
    ΓΙΑ y ΑΠΟ 8 ΜΕΧΡΙ x ΜΕ ΒΗΜΑ -1
      ΑΝ ΧΡΟΝΟΣ[y - 1] > ΧΡΟΝΟΣ[y] ΤΟΤΕ
        temp1 <-- ΧΡΟΝΟΣ[y-1]
        ΧΡΟΝΟΣ[y-1] <-- ΧΡΟΝΟΣ[y]
        ΧΡΟΝΟΣ[y] <-- temp1
        temp2 <-- ΑΘΛΗΤΗΣ[y-1,1]
        ΑΘΛΗΤΗΣ[y-1,1] <-- ΑΘΛΗΤΗΣ[y,1]
        ΑΘΛΗΤΗΣ[y,1] <-- temp2
        temp2 <-- ΑΘΛΗΤΗΣ[y-1,2]
        ΑΘΛΗΤΗΣ[y-1,2] <-- ΑΘΛΗΤΗΣ[y,2]
        ΑΘΛΗΤΗΣ[y,2] <-- temp2
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ΕΜΦΑΝΙΣΗ ΑΠΟΤΕΛΕΣΜΑΤΩΝ

  ΓΡΑΨΕ
  ΓΡΑΨΕ '===================================='
  ΓΡΑΨΕ 'ΧΡΟΝΟΣ          ΟΝΟΜΑ           ΧΩΡΑ'
  ΓΙΑ x ΑΠΟ 1 ΜΕΧΡΙ 8
    ΓΡΑΨΕ ΧΡΟΝΟΣ[x], ΑΘΛΗΤΗΣ[x,1], ΑΘΛΗΤΗΣ[x,2]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ '===================================='

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΑΘΛΗΤΕΣ


 


Κορυφή
 Προφίλ  
Απάντηση με παράθεση  
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τρί 23 Δεκ 2003 02:31 pm 
Χωρίς σύνδεση

Εγγραφή: Πέμ 01 Μάιος 2003 10:25 pm
Δημοσιεύσεις: 38
Τοποθεσία: Καλλιθέα Αττικής
Μπορείς να το πετύχεις χωρίς μετακίνηση στοιχείων;
- Να έχεις έναν πίνακα που κάθε στοιχείο θα δείχνει το στοιχείο της σωστής σειράς. Δηλαδή έμμεση διευθυνσιοδότηση (indirect addressing),

Οι διευθύνσεις εδώ είναι δείκτες - indexes- ενώ αν η υλοποίηση γίνονταν στην μνήμη του υπολογιστή θα ήταν μετατοπίσεις - offsets- (σχετική θέση από μια αρχή -origin-), ή σε με άμεση διευθυνσιοδότηση- pointers-
(απευθείας δείχνουμε την μνήμη που θα ξεκινήσει η μεταφορά από και προς το κεντρικό καταχωρητή: συσσωρευτή)

Αυτά τα τρία πράγματα: index, offset, pointer είναι βασικά θέματα. Η Basic όπως και η ΓΛΩΣΣΑ δουλεύει με indexes, όταν κάνει προσπέλαση στους πίνακες. Αυτό δεν σημαίνει ότι δεν μπορούμε να χρησιμοποιήσουμε offsets και pointers. Απλά αυτά θα μετατρέπονται σε indexes. Δηλαδή και εδώ σταματώ την ανάλυση, οι τρόποι προσπέλασης μπορούν να εξομοιωθούν σε κάθε περιβάλλον, είτε μνήμη το λέμε, είτε πίνακα (που είναι μορφοποιημένη μνήμη βάσει λογισμικού)

_________________
Γλώσσα προγραμματισμού M2000


Κορυφή
 Προφίλ  
Απάντηση με παράθεση  
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές: