Τώρα είναι Πέμ 27 Ιαν 2022 02:14 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΑΘΛΗΤΕΣ 2
ΔημοσίευσηΔημοσιεύτηκε: Τρί 26 Δεκ 2006 11:18 am 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! Στους προκριματικούς αγώνες του μήκους στο παγκόσμιο πρωτάθλημα του 2006
! τέθηκαν ως όριο πρόκρισης τα 8 μέτρα. Κάθε αθλητής που συμμετέχει στον αγώνα
! έχει δικαίωμα να κάνει τρία άλματα.
! Να γράψετε πρόγραμμα το οποίο :
!  · δέχεται τα ονόματα 20 αθλητών που πήραν μέρος στους προκριματικούς
!  · δέχεται τις επιδόσεις κάθε αθλητή στα τρία άλματα που έκανε και
!  · εμφανίζει πόσοι και ποιοι αθλητές προκρίνονται με σειρά επιτυχίας.
!
ΠΡΟΓΡΑΜΜΑ ΕΠ_1_11
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:i ,j ,Ν
  ΠΡΑΓΜΑΤΙΚΕΣ: alma[20,3] , best[20],temp1
  ΧΑΡΑΚΤΗΡΕΣ: name[20],temp2
ΑΡΧΗ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΡΑΨΕ 'Δώσε το όνομα τοθ αθλητή Νο :',i
    ΔΙΑΒΑΣΕ name[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 3
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
      ΓΡΑΨΕ 'Την επίδοση στο',j,'άλμα, του αθλητή',name[i]
      ΔΙΑΒΑΣΕ alma[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    best[i] <-- alma[i,1]
    ΓΙΑ j ΑΠΟ 2 ΜΕΧΡΙ 3
      ΑΝ alma[i,j] > best[i] ΤΟΤΕ
        best[i] <-- alma[i,j]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 20
    ΓΙΑ j ΑΠΟ 20 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ best[j-1] < best[j] ΤΟΤΕ      
        temp1 <-- best[j-1]
        best[j-1] <-- best[j]
        best[j] <-- temp1
        temp2 <-- name[j-1]
        name[j-1] <-- name[j]
        name[j] <-- temp2
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Ν <-- 1
  ΓΡΑΨΕ 'ΠΡΟΚΡΙΝΟΝΤΑΙ ΟΙ ΕΞΗΣ ΑΘΛΗΤΕΣ'
  ΓΡΑΨΕ '============================'
  ΟΣΟ best[Ν] >= 8 ΕΠΑΝΑΛΑΒΕ
    Ν <-- Ν + 1
    ΓΡΑΨΕ name[Ν] , 'με επίδοση',best[Ν],'m.'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Ν <-- Ν -1
  ΓΡΑΨΕ '============================'
  ΓΡΑΨΕ 'ΣΥΝΟΛΟ', Ν ,'ΑΘΛΗΤΕΣ'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
Απάντηση με παράθεση  
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές: