Τώρα είναι Κυρ 14 Αύγ 2022 12:05 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΕΛΕΓΧΟΣ ΒΑΘΜΟΛΟΓΙΩΝ
ΔημοσίευσηΔημοσιεύτηκε: Παρ 10 Μαρ 2006 07:23 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 04 Μαρ 2006 03:33 pm
Δημοσιεύσεις: 9
Παράθεση:
ΑΥΤΟ ΤΟ ΠΡΟΓΡΑΜΜΑ ΔΕΧΕΤΑΙ 5 ΒΑΘΜΟΛΟΓΙΕΣ ΥΠΟΛΟΓΙΖΕΙ ΤΟΝ ΜΕΣΟ ΟΡΟ ΤΟΥΣ , ΤΙΣ ΚΑΤΑΤΑΣΕΙ ΣΕ ΑΥΞΟΥΣΑ ΣΕΙΡΑ ΕΜΦΑΝΙΖΕΙ ΤΗΝ ΠΡΩΤΗ ΚΑΙ ΤΗΝ ΤΕΛΕΥΤΑΙΑ ΘΕΣΗ ΩΣ ΜΙΝ ΚΑΙ ΜΑΧ ΑΝΤΙΣΤΟΙΧΑ,ΕΜΦΑΝΙΖΕΙ ΠΟΣΟΙ ΕΙΝΑΙ ΠΑΝΩ ΑΠΟ ΤΟΝ ΜΕΣΟ ΟΡΟ ΚΑΙ ΠΟΣΟΙ ΕΙΧΑΝ 20


Syntax: [ Download ] [ Hide ]
πρόγραμμα fisiki

μεταβλητές
  ακέραιες:fis[5],i,j,max,min,temp,k20,kmo
  ΠΡΑΓΜΑΤΙΚΕΣ: mo

αρχή
  για i από 1 μέχρι 5
    αρχή_επανάληψης

      διάβασε fis[i]
    μέχρις_ότου (fis[i]>=0) και (fis[i]<=20)


    mo <-- mo+fis[i]/5
    αν fis[i]=20 τότε
      k20 <-- k20+1
    τέλος_αν

  τέλος_επανάληψης
  min <-- fis[1]
  max <-- fis[1]
  για i από 2 μέχρι 5
    για j από 5 μέχρι i με βήμα -1
      αν fis[j-1]>fis[j] τότε
        temp <-- fis[j]
        fis[j] <-- fis[j-1]
        fis[j-1] <-- temp
      τέλος_αν
    τέλος_επανάληψης
  τέλος_επανάληψης
  γράψε 'o mesos oros einai   ',mo
  για i από 1 μέχρι 5
    αν fis[i]>mo τότε
      kmo <-- kmo+1
    τέλος_αν
  τέλος_επανάληψης
  γράψε 'o mikroteros einai ' ,fis[1]
  γράψε ' o megaliteros  einai  ',fis[5]
  γράψε 'bathmoi pano apo ton meso oro  ',kmo
  γράψε 'bathmoi 20  ', k20
τέλος_προγράμματος


 


Κορυφή
 Προφίλ  
Απάντηση με παράθεση  
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές: