Τώρα είναι Κυρ 14 Αύγ 2022 11:58 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Τιμοκατάλογος εστιατορίου
ΔημοσίευσηΔημοσιεύτηκε: Παρ 23 Ιούλ 2004 08:35 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! ==============================================
! Κάποιο εστιατόριο θέλει να εκτυπώσει έναν
! αλφαβητικό τιμοκατάλογο των φαγητών που
! προσφέρει. Να γίνει πρόγραμμα που να ζητάει
! την ονομασία και την τιμή για 20 φαγητά και
! στη συνέχεια να εμφανίζει αυτά τα στοιχεία
! ταξινομημένα σε αλφαβητική σειρά.
! ==============================================


ΠΡΟΓΡΑΜΜΑ Τιμοκατάλογος_εστιατορίου

ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ονόματα[20], βοηθητική_χαρ
  ΑΚΕΡΑΙΕΣ: i, j, τιμές[20], βοηθητική_ακερ

ΑΡΧΗ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΡΑΨΕ 'Δώσε το όνομα του ', i, 'ου φαγητού:'
    ΔΙΑΒΑΣΕ ονόματα[i]
    ΓΡΑΨΕ 'Δώσε την τιμή αυτού του φαγητού:'
    ΔΙΑΒΑΣΕ τιμές[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 20
    ΓΙΑ j ΑΠΟ 20 ΜΕΧΡΙ i ΜΕ ΒΗΜΑ -1
      ΑΝ ονόματα[j-1]>ονόματα[j] ΤΟΤΕ

        βοηθητική_χαρ <-- ονόματα[j-1]
        ονόματα[j-1] <-- ονόματα[j]
        ονόματα[j] <-- βοηθητική_χαρ

        βοηθητική_ακερ <-- τιμές[j-1]
        τιμές[j-1] <-- τιμές[j]
        τιμές[j] <-- βοηθητική_ακερ

      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'ΑΛΦΑΒΗΤΙΚΟΣ ΤΙΜΟΚΑΤΑΛΟΓΟΣ ΦΑΓΗΤΩΝ'
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΡΑΨΕ  ονόματα[i], '  ', τιμές[i], '  ευρώ'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Τιμοκατάλογος_εστιατορίου

 

Ενδεικτικό αρχείο δεδομένων:
(χαρακτηριστικό που υλοποιήθηκε στην έκδοση 8 της ΓλωσσοΜάθειας)
Παράθεση:
Πατάτες τηγανητές
1
Πατάτες φούρνου
2
Μακαρόνια
3
Ψαρόσουπα
4
Παστίτσιο
4
Κοτόπουλο σούβλας
4
Κοτόπουλο φούρνου
4
Κοτόσουπα
3
Γεμιστές ντομάτες
3
Φασολάκια
2
Ντολμαδάκια
3
Κοκορέτσι
2
Φασόλια
2
Φακές
2
Γαλοπούλα
4
Σαλάτα εποχής
2
Αρακάς με κρέας
3
Ρύζι με κρέας
2
Κριθαράκι
2
Μανιτάρια
3

(Σημείωση: Χρησιμοποιείστε την "Καταγραφή εκτέλεσης" για να δείτε όλα τα αποτελέσματα του προγράμματος)


Κορυφή
 Προφίλ  
Απάντηση με παράθεση  
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές: