Τώρα είναι Δευτ 06 Φεβ 2023 09:54 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 13 Οκτ 2022 12:27 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 10 Οκτ 2012 04:00 am
Δημοσιεύσεις: 8
Το παρακάτω πρόγραμμα υπολογίζει μερικά βασικά αστρονομικά μεγέθη.

Φαινόμενο μέγεθος = πόσο μεγάλο φαίνεται από τη Γη
Απόλυτο μέγεθος = Πραγματικό μέγεθος
Parsec = 3.26 έτη φωτός

Το μέγεθος έχει ΑΝΑΠΟΔΗ λογική. Όσο μικρότερη η τιμή του, τόσο πιο λαμπρό το άστρο.
Επίσης μπορεί να πάρει και ΑΡΝΗΤΙΚΕΣ τιμές !! (Ο ήλιος π.χ. έχει απόλυτο μέγεθος -27)!!

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Μέγεθος_και_Λαμπρότητα_Αστέρων
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Γ,Δ,Ι,Θ
  ΠΡΑΓΜΑΤΙΚΕΣ: Α[5][5]
  ΧΑΡΑΚΤΗΡΕΣ: Ζ[5]
ΑΡΧΗ
  Ζ[1] <-- 'Απόλυτο Μέγεθος'
  Ζ[2] <-- 'Φαινόμενο Μέγεθος'
  Ζ[3] <-- 'Λαμπρότητα'
  Ζ[4] <-- 'Απόσταση σε Έτη Φωτός'
  Ζ[5] <-- 'Απόσταση σε Parsec'
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
    Β[Ι] <-- 0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Θέλετε να κάνετε υπολογισμό ή μετατροπή;'
  ΓΡΑΨΕ 'Πληκτρολογήστε:'
  ΓΡΑΨΕ ' 1 για υπολογισμό'
  ΓΡΑΨΕ ' 2 για μετατροπή'
  Γ <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    Θ <-- 0
    ΑΝ Γ>0 ΤΟΤΕ
      ΓΡΑΨΕ 'Λάθος δεδομένα προσπαθήστε ξανά'
    ΤΕΛΟΣ_ΑΝ
    ΔΙΑΒΑΣΕ Θ
    ΓΡΑΨΕ ''
    Γ <-- 1
  ΜΕΧΡΙΣ_ΟΤΟΥ Θ>0 ΚΑΙ Θ<3
  ΑΝ Θ=2 ΤΟΤΕ
    ΓΡΑΨΕ 'Πληκτρολογήστε για μετατροπή:'
    ΓΡΑΨΕ ' 1 από'[1],'σε'[3]
    ΓΡΑΨΕ ' 2 από'[3],'σε'[1]
    ΓΡΑΨΕ ' 3 από διαφορά σε'[1],'σε διαφορά σε'[3]
    ΓΡΑΨΕ ' 4 από διαφορά σε'[3],'σε διαφορά σε'[1]
    Δ <-- 0
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΝ Δ>0 ΤΟΤΕ
        ΓΡΑΨΕ 'Λάθος δεδομένα προσπαθήστε ξανά'
      ΤΕΛΟΣ_ΑΝ
      ΔΙΑΒΑΣΕ Γ
      ΓΡΑΨΕ ''
      Δ <-- 1
    ΜΕΧΡΙΣ_ΟΤΟΥ Γ>0 ΚΑΙ Γ<5
    ΓΡΑΨΕ ''
    ΕΠΙΛΕΞΕ Γ
      ΠΕΡΙΠΤΩΣΗ 1
        ΓΡΑΨΕ 'Δώστε τιμή για'[1]
        ΔΙΑΒΑΣΕ Α[1]
        ΓΡΑΨΕ ''
        Β[1] <-- 1
        Α[3] <-- 10^((4.83-Α[1])/2.5)
        Β[3] <-- 1
      ΠΕΡΙΠΤΩΣΗ 2
        ΓΡΑΨΕ 'Δώστε τιμή για'[3]
        ΔΙΑΒΑΣΕ Α[3]
        ΓΡΑΨΕ ''
        Β[3] <-- 1
        Α[1] <-- 4.83-2.5*ΛΟΓ(Α[3])/ΛΟΓ(10)
        Β[1] <-- 1
      ΠΕΡΙΠΤΩΣΗ 3
        ΓΡΑΨΕ 'Δώστε τη διαφορά σε'[1]
        ΔΙΑΒΑΣΕ Α[3]
        ΓΡΑΨΕ ''
        Β[3] <-- 1
        Α[1] <-- 100^(Α[3]/5)
        Β[1] <-- 1
      ΠΕΡΙΠΤΩΣΗ 4
        ΓΡΑΨΕ 'Δώστε τη διαφορά σε'[3]
        ΔΙΑΒΑΣΕ Α[1]
        ΓΡΑΨΕ ''
        Β[1] <-- 1
        Α[3] <-- 2.5*ΛΟΓ(Α[1])/ΛΟΓ(10)
        Β[3] <-- 1
    ΤΕΛΟΣ_ΕΠΙΛΟΓΩΝ
  ΑΛΛΙΩΣ
    ΓΙΑ Γ ΑΠΟ 1 ΜΕΧΡΙ 5
      Α[Γ] <-- 0
      Β[Γ] <-- 0
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Πληκρολογήστε:'
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
      ΓΡΑΨΕ '',Ι,'για'[Ι]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'Για να υπολογιστούν ΟΛΕΣ οι μεταβλητές'
    ΓΡΑΨΕ 'πρέπει να δοθούν ΤΟΥΛΑΧΙΣΤΟΝ 2 από τις 5.'
    ΓΡΑΨΕ 'Αν δώσετε 2, τότε ΟΧΙ τα ζευγάρια 1,3 ή 4,5'
    ΓΡΑΨΕ ''
    Θ <-- 0
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      Γ <-- 0
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΑΝ Γ>0 ΤΟΤΕ
          ΓΡΑΨΕ 'Λάθος δεδομένα προσπαθήστε ξανά'
        ΤΕΛΟΣ_ΑΝ
        ΔΙΑΒΑΣΕ Δ
        ΓΡΑΨΕ ''
        Γ <-- 1
      ΜΕΧΡΙΣ_ΟΤΟΥ Δ>0 ΚΑΙ Δ<6
      ΓΡΑΨΕ 'Δώστε την τιμή'
      ΔΙΑΒΑΣΕ Α[Δ]
      ΓΡΑΨΕ ''
      Β[Δ] <-- 1
      Γ <-- 0
      Θ <-- Θ+1
      ΓΡΑΨΕ 'Θέλετε να δώσετε κι άλλα δεδομένα ;'
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        ΑΝ Γ>0 ΤΟΤΕ
          ΓΡΑΨΕ 'Λάθος δεδομένα προσπαθήστε ξανά'
        ΤΕΛΟΣ_ΑΝ
        ΓΡΑΨΕ 'Πληκτρολογήστε:'
        ΓΡΑΨΕ '1 για ΝΑΙ'
        ΓΡΑΨΕ '2 για ΟΧΙ'
        ΔΙΑΒΑΣΕ Δ
        ΓΡΑΨΕ ''
        Γ <-- 1
      ΜΕΧΡΙΣ_ΟΤΟΥ Δ=1 Η Δ=2
      ΑΝ ((Β[1]+Β[3]=2) Η (Β[4]+Β[5]=2)) ΚΑΙ Θ=2 ΤΟΤΕ
        ΓΡΑΨΕ 'Δεν μπορούν να υπολογιστούν όλες οι μεταβλητές'
        ΓΡΑΨΕ 'γιατί τα δεδομένα είναι ελλειπή'
        Θ <-- 0
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ Δ=2
    ΑΝ Β[4]=1 ΤΟΤΕ
      Α[5] <-- Α[4]/3.26156
      Β[5] <-- 1
      Δ <-- 0
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Β[3]=1 ΤΟΤΕ
      Α[1] <-- 4.83-2.5*ΛΟΓ(Α[3])/ΛΟΓ(10)
      Β[1] <-- 1
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Β[1]+Β[2]+Β[5]=2 ΤΟΤΕ
      ΑΝ Β[1]=0 ΤΟΤΕ
        Α[1] <-- Α[2]-5*ΛΟΓ(Α[5])/ΛΟΓ(10)+5
        Β[1] <-- 1
      ΤΕΛΟΣ_ΑΝ
      ΑΝ Β[2]=0 ΤΟΤΕ
        Α[2] <-- Α[1]+5*ΛΟΓ(Α[5])/ΛΟΓ(10)-5
        Β[2] <-- 1
      ΤΕΛΟΣ_ΑΝ
      ΑΝ Β[5]=0 ΚΑΙ Δ>0 ΤΟΤΕ
        Α[5] <-- 10^((Α[2]-Α[1])/5+1)
        Β[5] <-- 1
        Α[4] <-- Α[5]*3.26156
        Β[4] <-- 1
      ΤΕΛΟΣ_ΑΝ
      ΑΝ Β[1]=1 ΤΟΤΕ
        Α[3] <-- 100^((4.83-Α[1])/5)
        Β[3] <-- 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
  ΓΙΑ Δ ΑΠΟ 1 ΜΕΧΡΙ 5
    ΑΝ Β[Δ]=1 ΤΟΤΕ
      ΓΡΑΨΕ Ζ[Δ],':'[Δ]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

_________________
"Peace to everyone, and - who knows ? - maybe one day ... civilization !!!" - Pat Condell


Κορυφή
 Προφίλ  
Απάντηση με παράθεση  
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές: