Τώρα είναι Τρί 23 Ιούλ 2019 04:09 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Παρ 02 Μάιος 2003 01:42 am 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Syntax: [ Download ] [ Hide ]
! ==========================================
! Σε τρεις διαφορετικούς αγώνες πρόκρισης
! για την Ολυμπιάδα του Σίδνεϋ στο άλμα εις
! μήκος ένας αθλητής πέτυχε τις επιδόσεις a,
! b, c. Να γίνει πρόγραμμα το οποίο:
!   Α) Να διαβάζει τις τιμές των επιδόσεων
!      a, b, c.
!                                [Μονάδες 3]
!   Β) Να υπολογίζει και να εμφανίζει τη
!      μέση τιμή των παραπάνω τιμών. Αν σε
!      κάποια άλματα έχει δοθεί τιμή ίση με
!      μηδέν (δηλαδή άκυρα άλματα), ο μέσος
!      όρος θα πρέπει να υπολογίζεται από
!      τις υπόλοιπες μη-μηδενικές τιμές.
!                                [Μονάδες 7]
!   Γ) Να εμφανίζει το μήνυμα "Προκρίθηκε",
!      αν η παραπάνω μέση τιμή είναι
!      μεγαλύτερη των 8 μέτρων.
!                               [Μονάδες 10]
! ==========================================


ΠΡΟΓΡΑΜΜΑ Πανελλήνιες_2000__Θέμα_3ο__εμπλουτισμένο

ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: a, b, c, μέσος_όρος
  ΑΚΕΡΑΙΕΣ: Ν

ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε την πρώτη επίδοση:'
  ΔΙΑΒΑΣΕ a
  ΓΡΑΨΕ 'Δώσε τη δεύτερη επίδοση:'
  ΔΙΑΒΑΣΕ b
  ΓΡΑΨΕ 'Δώσε την τρίτη επίδοση:'
  ΔΙΑΒΑΣΕ c

  Ν <-- 3
  ΑΝ a=0 ΤΟΤΕ
    Ν <-- Ν-1
  ΤΕΛΟΣ_ΑΝ
  ΑΝ b=0 ΤΟΤΕ
    Ν <-- Ν-1
  ΤΕΛΟΣ_ΑΝ
  ΑΝ c=0 ΤΟΤΕ
    Ν <-- Ν-1
  ΤΕΛΟΣ_ΑΝ

  ΑΝ Ν>0 ΤΟΤΕ
    μέσος_όρος <-- (a+b+c)/Ν
  ΑΛΛΙΩΣ
    μέσος_όρος <-- 0
  ΤΕΛΟΣ_ΑΝ

  ΓΡΑΨΕ μέσος_όρος

  ΑΝ μέσος_όρος>8 ΤΟΤΕ
    ΓΡΑΨΕ 'Προκρίθηκε'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Πανελλήνιες_2000__Θέμα_3ο__εμπλουτισμένο

 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters