Τώρα είναι Πέμ 22 Αύγ 2019 09:28 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 27 Ιαν 2007 02:47 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 27 Ιαν 2007 02:27 pm
Δημοσιεύσεις: 4
Τοποθεσία: Κομοτηνή
Κατασκευάστε αλγόριθμο, ο οποίος θα δέχεται έναν ακέραιο αριθμό με το πολύ 5 ψηφία και να εμφανίζει ένα προς ένα τα ψηφία του. Στη συνέχεια, θα εμφανίζει τον αριθμό που προκύπτει αν αντιστραφεί η σειρά των ψηφίων του.

Π.Χ. Για είσοδο 13579, θα εμφανίσει πρώτα 1 3 5 7 9 και στη
συνέχεια 9 7 5 3 1.

_________________
Αντωνόπουλος Αντώνης


Τελευταία επεξεργασία από Antonopoulos Antonis και Κυρ 28 Ιαν 2007 07:18 pm, έχει επεξεργασθεί 1 φορά/ες συνολικά

Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 27 Ιαν 2007 05:22 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 04 Νοέμ 2006 01:07 am
Δημοσιεύσεις: 20
Οι μεταβλητες στη Γλωσσομαθεια δεχονται αριθμους το πολυ με 10 ψηφια...


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 27 Ιαν 2007 05:44 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 04 Νοέμ 2006 01:07 am
Δημοσιεύσεις: 20
Ετοιμο :P

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ασδφ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:ι,υ,Α[10],αριθμος, ν
  ΠΡΑΓΜΑΤΙΚΕΣ: χ

ΑΡΧΗ

    ΔΙΑΒΑΣΕ αριθμος

  ΓΙΑ ι ΑΠΟ 0 ΜΕΧΡΙ 9
    ΑΝ αριθμος>=10^ι και αριθμος<(10^ι)*10 ΤΟΤΕ
      ν <-- ι+1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  υ <-- 0

  ΓΙΑ ι ΑΠΟ ν-1 ΜΕΧΡΙ 0 ΜΕ ΒΗΜΑ -1
    υ <-- υ+1
    χ <-- 10^ι
    Α[υ] <-- αριθμος DIV Α_Μ(χ)
    αριθμος <-- αριθμος MOD Α_Μ(χ)
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ ι ΑΠΟ ν ΜΕΧΡΙ 1 ΜΕ ΒΗΜΑ -1
    ΓΡΑΨΕ_ Α[ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ασδφ


Ειναι για αριθμους με 1 μεχρι 10 ψηφια


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 3 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 0 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters