Τώρα είναι Δευτ 21 Σεπ 2020 03:18 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 28 Ιούλ 2008 12:48 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ==============================================================================
! ΕΣΠΕΡΙΝΟ - ΙOYΛIΟΣ 2008 - ΘΕΜΑ 2
! ==============================================================================
!  Δίνεται το παρακάτω τμήμα αλγορίθμου:
!
!    Χ <-- 0
!    Α <-- 10
!    Β <-- 14
!    ΟΣΟ Β > 0 ΕΠΑΝΑΛΑΒΕ
!      ΑΝ Β MOD 2 = 0 ΤΟΤΕ
!        Χ <-- Χ + Α
!      ΤΕΛΟΣ_ΑΝ
!      Α <-- Α*2
!      B <-- B DIV 2
!    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!
!  α. Να γράψετε στο τετράδιό σας τις τιμές των μεταβλητών Χ, Α και Β στο τέλος
!     κάθε επανάληψης κατά την εκτέλεση του παραπάνω τμήματος αλγορίθμου.
!  β. Να σχεδιάσετε το αντίστοιχο διάγραμμα ροής.
! ==============================================================================

ΠΡΟΓΡΑΜΜΑ  ESP_2008_07_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : x , a , b
ΑΡΧΗ

  x <-- 0
  a <-- 10
  b <-- 14
  ΟΣΟ b > 0 ΕΠΑΝΑΛΑΒΕ
    ΑΝ b MOD 2 = 0 ΤΟΤΕ
      x <-- x + a
    ΤΕΛΟΣ_ΑΝ
    a <-- a*2
    b <-- b DIV 2
    ΓΡΑΨΕ x , a , b
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters