Τώρα είναι Σάβ 22 Νοέμ 2014 02:52 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: ΑΡΙΘΜΟΜΗΧΑΝΗ
ΔημοσίευσηΔημοσιεύτηκε: Τετ 18 Μαρ 2009 02:11 pm 
Χωρίς σύνδεση

Εγγραφή: Παρ 06 Μαρ 2009 10:03 pm
Δημοσιεύσεις: 13
Τοποθεσία: Σέρρες
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΑΡΗΘΜΟΜΗΧΑΝΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ : Α , Χ , Υ , Ω , Π , Ο
ΑΡΧΗ
  Π <-- 1
  ΟΣΟ Π = 1 ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 1 ΓΙΑ ΠΡΟΣΘΕΣΗ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 2 ΓΙΑ ΑΦΕΡΕΣΗ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 3 ΓΙΑ ΠΟΛΛΑΠΛΑΣΙΑΣΜΟ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 4 ΓΙΑ ΔΙΕΡΕΣΗ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 5 ΓΙΑ ΑΡΗΘΜΟ ΣΤΟ ΤΕΤΡΑΓΩΝΟ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 6 ΓΙΑ ΑΡΗΘΜΟ ΣΤΗΝ ΡΙΖΑ '
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 7 ΓΙΑ 1/x '
    ΔΙΑΒΑΣΕ Α
    ΑΝ Α = 1 ΤΟΤΕ
      ΓΡΑΨΕ ' ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΤΟΥΣ ΔΥΟ ΑΡΙΘΜΟΥΣ ΠΟΥ ΘΕΛΕΤΕ ΝΑ ΠΡΟΣΘΕΣΕΤΕ '
      ΔΙΑΒΑΣΕ Χ , Υ
      Ω <-- Χ + Υ
      ΓΡΑΨΕ ' ΤΟ ΑΘΡΟΙΣΜΑ ΤΩΝ ΔΥΟ ΑΡΙΘΜΩΝ ΕΙΝΑΙ ', Ω
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Α = 2 ΤΟΤΕ
      ΓΡΑΨΕ ' ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΤΟΥΣ ΔΥΟ ΑΡΙΘΜΟΥΣ ΠΟΥ ΘΕΛΕΤΕ ΝΑ ΑΦΕΡΕΣΕΤΕ ΜΕ ΣΩΣΤΗ ΣΕΙΡΑ '
      ΔΙΑΒΑΣΕ Χ , Υ
      Ω <-- Χ - Υ
      ΓΡΑΨΕ ' Η ΔΙΑΦΟΡΑ ΤΩΝ ΔΥΟ ΑΡΗΘΜΩΝ ΕΙΝΑΙ ', Ω
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Α = 3 ΤΟΤΕ
      ΓΡΑΨΕ ' ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΤΟΥΣ ΔΥΟ ΑΡΙΘΜΟΥΣ ΠΟΥ ΘΕΛΕΤΕ ΝΑ ΠΟΛΛΑΠΛΑΣΙΑΣΕΤΕ '
      ΔΙΑΒΑΣΕ Χ , Υ
      Ω <-- Χ * Υ
      ΓΡΑΨΕ ' ΤΟ ΓΙΝΟΜΕΝΟ ΤΩΝ ΔΥΟ ΑΡΙΘΜΩΝ ΕΙΝΑΙ ', Ω
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Α = 4 ΤΟΤΕ
      ΓΡΑΨΕ ' ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΤΟΥΣ ΔΥΟ ΑΡΗΘΜΟΥΣ ΠΟΥ ΘΕΛΕΤΕ ΝΑ ΔΙΕΡΕΣΕΤΕ ΜΕ ΣΩΣΤΗ ΣΕΙΡΑ '
      ΔΙΑΒΑΣΕ Χ , Υ
      Ω <-- Χ / Υ
      ΓΡΑΨΕ ' ΤΟ ΠΟΙΛΙΚΟ ΤΩΝ ΔΥΟ ΑΡΗΘΜΩΝ ΕΙΝΑΙ ', Ω
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Α = 5 ΤΟΤΕ
      ΓΡΑΨΕ ' ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΤΟΝ ΑΡΗΘΜΟ ΠΟΥ ΘΕΛΕΤΕ ΣΤΟ ΤΕΤΡΑΓΩΝΟ '
      ΔΙΑΒΑΣΕ Χ
      Ω <-- Χ ^ 2
      ΓΡΑΨΕ ' Ο ΑΡΗΘΜΟΣ ΣΤΟ ΤΕΤΡΑΓΩΝΟ ΕΙΝΑΙ ', Ω
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Α = 6 ΤΟΤΕ
      ΓΡΑΨΕ ' ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΤΟΝ ΑΡΙΘΜΟ ΠΟΥ ΘΕΛΕΤΕ ΣΤΗΝ ΡΙΖΑ '
      ΔΙΑΒΑΣΕ Χ
      Ω <-- Τ_Ρ ( Χ )
      ΓΡΑΨΕ ' Ο ΑΡΗΘΜΟΣ ΣΤΗΝ ΡΙΖΑ ΕΙΝΑΙ ', Ω
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Α = 7 ΤΟΤΕ
      ΓΡΑΨΕ ' ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΤΟΝ ΑΡΗΘΜΟ ΠΟΥ ΘΕΛΕΤΕ 1/x '
      ΔΙΑΒΑΣΕ Χ
      Ω <-- 1 / Χ
      ΓΡΑΨΕ ' Ο ΑΡΗΘΜΟΣ ΣΤΟ 1/x ΕΙΝΑΙ ', Ω
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ ' ΠΑΤΗΣΤΕ 1 ΓΙΑ ΤΕΡΜΑΤΙΣΜΟ Ή 2 ΓΙΑ ΣΥΝΕΧΕΙΑ '
    ΔΙΑΒΑΣΕ Ο
    ΑΝ Ο = 2 ΤΟΤΕ
      Π <-- 1
    ΤΕΛΟΣ_ΑΝ
    ΑΝ Ο = 1 ΤΟΤΕ
      Π <-- 2
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ ' BY : ΚΩΣΤΑΣ Λ. ΑΠΟ Β ΛΥΚΕΙΟΥ ΡΟΔΟΛΙΒΟΥΣ '
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΑΡΗΘΜΟΜΗΧΑΝΗ


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: ΑΡΙΘΜΟΜΗΧΑΝΗ
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 04 Ιουν 2009 06:41 pm 
Χωρίς σύνδεση

Εγγραφή: Τετ 22 Οκτ 2008 12:08 pm
Δημοσιεύσεις: 32
Τοποθεσία: Αθήνα
Ωραίος ρε , αλλά δυστυχώς δυσαρεστήθηκα αρκετά από τα ορθογραφικά σου λάθη στον κώδικα . Θα σε παρακαλούσα να τα διορθώσεις καθώς μπορεί να προγραμματίζουμε σε μια ψευδογλώσσα , όμως μην ξεχνάς ότι χρησιμοποιείς την ελληνική γλώσσα , οπότε σεβάσου την.

_________________
"The ultimate measure of a man is not where he stands in moments of comfort and convenience, but where he stands at times of challenge and controversy."
- Martin Luther King Jr. -


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 2 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές: