Ασκησιολόγιο ΓλωσσοΜάθειας
http://spinet.gr/glossomatheia/programs/

Επαναληπτικές Εσπερινό - Θέμα 2
http://spinet.gr/glossomatheia/programs/viewtopic.php?f=39&t=681
Σελίδα 1 από 1

Συγγραφέας:  ΧΑΤΖΗΤΣΟΜΠΑΝΗΣ ΘΕΟΦΙΛΟΣ [ Δευτ 28 Ιούλ 2008 12:48 pm ]
Θέμα δημοσίευσης:  Επαναληπτικές Εσπερινό - Θέμα 2

Syntax: [ Download ] [ Hide ]
! ==============================================================================
! ΕΣΠΕΡΙΝΟ - ΙOYΛIΟΣ 2008 - ΘΕΜΑ 2
! ==============================================================================
!  Δίνεται το παρακάτω τμήμα αλγορίθμου:
!
!    Χ <-- 0
!    Α <-- 10
!    Β <-- 14
!    ΟΣΟ Β > 0 ΕΠΑΝΑΛΑΒΕ
!      ΑΝ Β MOD 2 = 0 ΤΟΤΕ
!        Χ <-- Χ + Α
!      ΤΕΛΟΣ_ΑΝ
!      Α <-- Α*2
!      B <-- B DIV 2
!    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!
!  α. Να γράψετε στο τετράδιό σας τις τιμές των μεταβλητών Χ, Α και Β στο τέλος
!     κάθε επανάληψης κατά την εκτέλεση του παραπάνω τμήματος αλγορίθμου.
!  β. Να σχεδιάσετε το αντίστοιχο διάγραμμα ροής.
! ==============================================================================

ΠΡΟΓΡΑΜΜΑ  ESP_2008_07_2
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : x , a , b
ΑΡΧΗ

  x <-- 0
  a <-- 10
  b <-- 14
  ΟΣΟ b > 0 ΕΠΑΝΑΛΑΒΕ
    ΑΝ b MOD 2 = 0 ΤΟΤΕ
      x <-- x + a
    ΤΕΛΟΣ_ΑΝ
    a <-- a*2
    b <-- b DIV 2
    ΓΡΑΨΕ x , a , b
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

Σελίδα 1 από 1 Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/