Ασκησιολόγιο ΓλωσσοΜάθειας
http://spinet.gr/glossomatheia/programs/

Επαναληπτικές Ημερήσιο - Θέμα 2Α
http://spinet.gr/glossomatheia/programs/viewtopic.php?f=39&t=676
Σελίδα 1 από 1

Συγγραφέας:  ΧΑΤΖΗΤΣΟΜΠΑΝΗΣ ΘΕΟΦΙΛΟΣ [ Δευτ 28 Ιούλ 2008 12:45 pm ]
Θέμα δημοσίευσης:  Επαναληπτικές Ημερήσιο - Θέμα 2Α

Syntax: [ Download ] [ Hide ]
! ========================================================================
! ΗΜΕΡΗΣΙΟ - ΙOYΛIΟΣ 2008 - ΘΕΜΑ 2A
! ========================================================================
! Δίνεται το παρακάτω πρόγραμμα σε ΓΛΩΣΣΑ
!
!    1.  ΠΡΟΓΡΑΜΜΑ ΕΙΝΑΙ-ΠΡΩΤΟΣ
!    2.    ΜΕΤΑΒΛΗΤΕΣ
!    3.      ΑΚΕΡΑΙΕΣ: Χ, i
!    4.      ΧΑΡΑΚΤΗΡΕΣ: ΜΗΝΥΜΑ
!    5.    ΑΡΧΗ
!    6.     ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
!    7.       ΔΙΑΒΑΣΕ Χ
!    8.     ΜΕΧΡΙΣ_ΟΤΟΥ Χ > 0
!    9.     C <-- 0
!   10.    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Χ ΕΠΑΝΑΛΑΒΕ
!   11.      AN (Χ MOD i) = 0 TOTE
!   12.    C <-- C + 1
!   13.      ΤΕΛΟΣ_ΑΝ
!   14.    ΤΕΛΟΣ_ΓΙΑ
!   15.    ΑΝ C = 2 TOTE
!   16.      MHNYMA <-- "EINAI ΠΡΩΤΟΣ"
!   17.    ΑΛΛΙΩΣ
!   18.      ΜΗΝΥΜΑ <-- "ΔΕΝ ΕΙΝΑΙ ΠΡΩΤΟΣ"
!   19.    ΤΕΛΟΣ
!   20.    ΓΡΑΨΕ ΜΗΝΥΜΑ
!   21.  ΤΕΛΟΣ_ΑΛΓΟΡΙΘΜΟΥ
!
! Να γράψετε στο τετράδιό σας τον αριθμό κάθε γραμμής του προγράμματος,
! στην οποία εντοπίζετε συντακτικό λάθος και να περιγράψετε το λάθος αυτό.
! ========================================================================

ΠΡΟΓΡΑΜΜΑ ΕΙΝΑΙ_ΠΡΩΤΟΣ           !  1. Λέει ΕΙΝΑΙ-ΠΡΩΤΟΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: x , i  , C           !  3. Δεν είναι δηλωμένη η μεταβλητή C
  ΧΑΡΑΚΤΗΡΕΣ: ΜΗΝΥΜΑ
ΑΡΧΗ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ x
  ΜΕΧΡΙΣ_ΟΤΟΥ x > 0
  c <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ x ΕΠΑΝΑΛΑΒΕ
    ΑΝ (x MOD i) = 0 ΤΟΤΕ
      c <-- c + 1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ                 ! 14. Λέει ΤΕΛΟΣ_ΓΙΑ
  ΑΝ C = 2 ΤΟΤΕ
    MHNYMA <-- 'EINAI ΠΡΩΤΟΣ'
  ΑΛΛΙΩΣ
    ΜΗΝΥΜΑ <-- 'ΔΕΝ ΕΙΝΑΙ ΠΡΩΤΟΣ'
  ΤΕΛΟΣ_ΑΝ                         ! 19. Λέει απλώς ΤΕΛΟΣ
  ΓΡΑΨΕ ΜΗΝΥΜΑ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ                 ! 21. Λέει ΤΕΛΟΣ_ΑΛΓΟΡΙΘΜΟΥ
 

Σελίδα 1 από 1 Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/