Ασκησιολόγιο ΓλωσσοΜάθειας
http://spinet.gr/glossomatheia/programs/

Επαναληπτικές Ημερήσιο - Θέμα 1Ε
http://spinet.gr/glossomatheia/programs/viewtopic.php?f=39&t=674
Σελίδα 1 από 1

Συγγραφέας:  ΧΑΤΖΗΤΣΟΜΠΑΝΗΣ ΘΕΟΦΙΛΟΣ [ Δευτ 28 Ιούλ 2008 12:44 pm ]
Θέμα δημοσίευσης:  Επαναληπτικές Ημερήσιο - Θέμα 1Ε

Syntax: [ Download ] [ Hide ]
! ==============================================================
! ΗΜΕΡΗΣΙΟ - ΙOYΛIΟΣ 2008 - ΘΕΜΑ 1Ε
! ==============================================================
! Δίνεται το παρακάτω τμήμα αλγορίθμου:
!
!   Κ <-- 1
!   ΓΙΑ i ΑΠΟ -1 ΜΕΧΡΙ -5 ΜΕ_ΒΗΜΑ -2
!     Κ <-- Κ*i
!     ΓΡΑΨΕ Κ
!   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!
! Να μετατρέψετε το τμήμα αυτού του αλγορίθμου σε ισοδύναμο:
! α. με χρήση της αλγοριθμικής δομής ΟΣΟ
! β. με χρήση της αλγοριθμικής δομής ΜΕΧΡΙΣ_ΟΤΟΥ
! ==============================================================

ΠΡΟΓΡΑΜΜΑ ΗΜ_2008_07_1Ε
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i , k
ΑΡΧΗ

! ΑΡΧΙΚΟΣ ΑΛΓΟΡΙΘΜΟΣ
  k <-- 1
  ΓΙΑ i ΑΠΟ -1 ΜΕΧΡΙ -5 ΜΕ ΒΗΜΑ -2
    k <-- k * i
    ΓΡΑΨΕ k
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ΑΛΛΑΓΗ ΣΕ ΔΟΜΗ ΟΣΟ ....
  k <-- 1
  i <-- -1
  ΟΣΟ i >= -5 ΕΠΑΝΑΛΑΒΕ
    k <-- k*i
    ΓΡΑΨΕ k
    i <-- i-2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ΑΛΛΑΓΗ ΣΕ ΔΟΜΗ ΜΕΧΡΙΣ_ΟΤΟΥ ....
  k <-- 1
  i <-- -1
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    k <-- k*i
    ΓΡΑΨΕ k
    i <-- i-2
  ΜΕΧΡΙΣ_ΟΤΟΥ i < -5

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

Σελίδα 1 από 1 Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/