Τώρα είναι Δευτ 17 Ιουν 2019 06:20 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 28 Ιούλ 2008 12:44 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ==============================================================
! ΗΜΕΡΗΣΙΟ - ΙOYΛIΟΣ 2008 - ΘΕΜΑ 1Ε
! ==============================================================
! Δίνεται το παρακάτω τμήμα αλγορίθμου:
!
!   Κ <-- 1
!   ΓΙΑ i ΑΠΟ -1 ΜΕΧΡΙ -5 ΜΕ_ΒΗΜΑ -2
!     Κ <-- Κ*i
!     ΓΡΑΨΕ Κ
!   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!
! Να μετατρέψετε το τμήμα αυτού του αλγορίθμου σε ισοδύναμο:
! α. με χρήση της αλγοριθμικής δομής ΟΣΟ
! β. με χρήση της αλγοριθμικής δομής ΜΕΧΡΙΣ_ΟΤΟΥ
! ==============================================================

ΠΡΟΓΡΑΜΜΑ ΗΜ_2008_07_1Ε
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : i , k
ΑΡΧΗ

! ΑΡΧΙΚΟΣ ΑΛΓΟΡΙΘΜΟΣ
  k <-- 1
  ΓΙΑ i ΑΠΟ -1 ΜΕΧΡΙ -5 ΜΕ ΒΗΜΑ -2
    k <-- k * i
    ΓΡΑΨΕ k
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ΑΛΛΑΓΗ ΣΕ ΔΟΜΗ ΟΣΟ ....
  k <-- 1
  i <-- -1
  ΟΣΟ i >= -5 ΕΠΑΝΑΛΑΒΕ
    k <-- k*i
    ΓΡΑΨΕ k
    i <-- i-2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ΑΛΛΑΓΗ ΣΕ ΔΟΜΗ ΜΕΧΡΙΣ_ΟΤΟΥ ....
  k <-- 1
  i <-- -1
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    k <-- k*i
    ΓΡΑΨΕ k
    i <-- i-2
  ΜΕΧΡΙΣ_ΟΤΟΥ i < -5

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters