Τώρα είναι Δευτ 20 Μάιος 2019 02:07 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 4
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 28 Ιούλ 2008 12:42 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΜΑΙΟΣ 2008 - ΘΕΜΑ 4
! ===============================================================================================
! Ένας επενδυτής διέθεσε 10.000 € για την αγορά ορισμένων τεμαχίων 10 διαφορετικών μετοχών.
! Να γράψετε αλγόριθμο ο οποίος:
!  α. Για καθεμία από τις 10 μετοχές διαβάζει
!     o το όνομα της μετοχής,
!     o το πλήθος των τεμαχίων της μετοχής, που κατέχει ο επενδυτής, ελέγχοντας το πλήθος να
!       είναι θετικός αριθμός,
!       και καταχωρίζει τα δεδομένα αυτά σε σχετικούς πίνακες.
!  β. Για καθεμία από τις 10 μετοχές και για καθεμία από τις πέντε (5) εργάσιμες ημέρες της
!     εβδομάδας διαβάζει την τιμή ενός τεμαχίου της μετοχής και την αποθηκεύει σε κατάλληλο
!     πίνακα δύο διαστάσεων, ελέγχοντας η τιμή του τεμαχίου να είναι θετικός αριθμός.
!  γ. Για καθεμία από τις 10 μετοχές υπολογίζει τη μέση εβδομαδιαία τιμή του τεμαχίου της και
!     την αποθηκεύει σε μονοδιάστατο πίνακα.
!  δ. Υπολογίζει και εμφανίζει τη συνολική αξία όλων των τεμαχίων όλων των μετοχών του επενδυτή,
!     την τελευταία ημέρα της εβδομάδας.
!  ε. Υπολογίζει εάν ο επενδυτής στο τέλος της εβδομάδας έχει κέρδος ή ζημία ή καμία μεταβολή σε
!     σχέση με το αρχικό ποσό που διέθεσε, εμφανίζοντας κατάλληλα μηνύματα.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ  ESP_2008_05_4
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : x[10] , i , j                                        
  ΠΡΑΓΜΑΤΙΚΕΣ : p[10,5] , mo[10] , s
  ΧΑΡΑΚΤΗΡΕΣ : name[10]
ΑΡΧΗ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'Δώσε το όνομα της', i , 'μετοχής.'
    ΔΙΑΒΑΣΕ name[i]
    ΓΡΑΨΕ 'Πόσες τέτοιες μετοχές έχεις;'
    ΔΙΑΒΑΣΕ x[i]
    ΟΣΟ x[i] <=0 ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Λάθος. Ξαναδώσε'
      ΔΙΑΒΑΣΕ x[i]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'Δώσε την τιμή της μετοχής' , name[i]
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
      ΓΡΑΨΕ 'την' , j , 'μέρα της εβδομάδας.'
      ΔΙΑΒΑΣΕ p[i,j]
      ΟΣΟ p[i,j] <=0 ΕΠΑΝΑΛΑΒΕ
        ΓΡΑΨΕ 'Λάθος. Ξαναδώσε'
        ΔΙΑΒΑΣΕ p[i,j]
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    s <-- 0
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5
      s <-- s + p[i,j]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    mo[i] <-- s/5
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  s <-- 0                           ! ή αφού έχουμε βρεί τη μέση τιμή
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10              ! -------------------------------
    ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 5             ! s <-- 0
      s <-- s + p[i,j]*x[i]         ! ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 10
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ                !   s <-- s + x[i]*mo[i]*5
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ                  ! ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Συνολική αξία χαρτοφυλακίου μετοχών =' , s

  ΑΝ s > 10000 ΤΟΤΕ
    ΓΡΑΨΕ 'Κέρδος' , s-1000 , 'ευρώ.'
  ΑΛΛΙΩΣ_ΑΝ s < 10000 ΤΟΤΕ
    ΓΡΑΨΕ 'Ζημιά' , 10000- s , 'ευρώ.'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Καμμία μεταβολή.'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters