Τώρα είναι Τετ 23 Σεπ 2020 03:01 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Εσπερινό - Θέμα 2β
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 28 Ιούλ 2008 12:37 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΜΑΙΟΣ 2008 - ΘΕΜΑ 2β
! ===============================================================================================
! Δίνεται το παρακάτω τμήμα αλγορίθμου:
!
!  ΜΑΧ <-- Α[1]
!  ΜΙΝ <-- Α[1]
!  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
!    ΑΝ Α[i] < ΜΙΝ ΤΟΤΕ
!      ΜΙΝ <-- Α[i]
!    ΑΛΛΙΩΣ
!      ΑΝ Α[i] > MAX TOTE
!        ΜΑΧ <-- Α[i]
!      ΤΕΛΟΣ_ΑΝ
!    ΤΕΛΟΣ_ΑΝ
!  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!  ΕΜΦΑΝΙΣΕ ΜΙΝ , ΜΑΧ
!
! Να μετατρέψετε το παραπάνω τμήμα αλγορίθμου σε ισοδύναμο με χρήση της δομής επανάληψης
! ΟΣΟ ... ΕΠΑΝΑΛΑΒΕ.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ  ESP_2008_05_2b
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : a[5] , i , max , min
ΑΡΧΗ

! Προφανώς ο αλγόριθμος συγκρίνει τα στοιχεία ενός πίνακα a[5]
  a[1] <-- 0
  a[2] <-- 5
  a[3] <-- 12
  a[4] <-- -2
  a[5] <-- 20

! Αρχικός αλγόριθμος
  max <-- a[1]
  min <-- a[1]
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    ΑΝ a[i] < min ΤΟΤΕ
      min <-- a[i]
    ΑΛΛΙΩΣ
      ΑΝ a[i] > MAX ΤΟΤΕ
        max <-- a[i]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ                                                
  ΓΡΑΨΕ min , max

! Τελικός αλγόριθμος
  max <-- a[1]
  min <-- a[1]
  i <-- 1
  ΟΣΟ i <= 5 ΕΠΑΝΑΛΑΒΕ
    ΑΝ a[i] < min ΤΟΤΕ
      min <-- a[i]
    ΑΛΛΙΩΣ
      ΑΝ a[i] > MAX ΤΟΤΕ
        max <-- a[i]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    i <-- i + 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ min , max

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters