Ασκησιολόγιο ΓλωσσοΜάθειας
http://spinet.gr/glossomatheia/programs/

Εσπερινό - Θέμα 2β
http://spinet.gr/glossomatheia/programs/viewtopic.php?f=39&t=671
Σελίδα 1 από 1

Συγγραφέας:  ΧΑΤΖΗΤΣΟΜΠΑΝΗΣ ΘΕΟΦΙΛΟΣ [ Δευτ 28 Ιούλ 2008 12:37 pm ]
Θέμα δημοσίευσης:  Εσπερινό - Θέμα 2β

Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΜΑΙΟΣ 2008 - ΘΕΜΑ 2β
! ===============================================================================================
! Δίνεται το παρακάτω τμήμα αλγορίθμου:
!
!  ΜΑΧ <-- Α[1]
!  ΜΙΝ <-- Α[1]
!  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
!    ΑΝ Α[i] < ΜΙΝ ΤΟΤΕ
!      ΜΙΝ <-- Α[i]
!    ΑΛΛΙΩΣ
!      ΑΝ Α[i] > MAX TOTE
!        ΜΑΧ <-- Α[i]
!      ΤΕΛΟΣ_ΑΝ
!    ΤΕΛΟΣ_ΑΝ
!  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!  ΕΜΦΑΝΙΣΕ ΜΙΝ , ΜΑΧ
!
! Να μετατρέψετε το παραπάνω τμήμα αλγορίθμου σε ισοδύναμο με χρήση της δομής επανάληψης
! ΟΣΟ ... ΕΠΑΝΑΛΑΒΕ.
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ  ESP_2008_05_2b
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : a[5] , i , max , min
ΑΡΧΗ

! Προφανώς ο αλγόριθμος συγκρίνει τα στοιχεία ενός πίνακα a[5]
  a[1] <-- 0
  a[2] <-- 5
  a[3] <-- 12
  a[4] <-- -2
  a[5] <-- 20

! Αρχικός αλγόριθμος
  max <-- a[1]
  min <-- a[1]
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    ΑΝ a[i] < min ΤΟΤΕ
      min <-- a[i]
    ΑΛΛΙΩΣ
      ΑΝ a[i] > MAX ΤΟΤΕ
        max <-- a[i]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ                                                
  ΓΡΑΨΕ min , max

! Τελικός αλγόριθμος
  max <-- a[1]
  min <-- a[1]
  i <-- 1
  ΟΣΟ i <= 5 ΕΠΑΝΑΛΑΒΕ
    ΑΝ a[i] < min ΤΟΤΕ
      min <-- a[i]
    ΑΛΛΙΩΣ
      ΑΝ a[i] > MAX ΤΟΤΕ
        max <-- a[i]
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
    i <-- i + 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ min , max

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

Σελίδα 1 από 1 Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/