Ασκησιολόγιο ΓλωσσοΜάθειας
http://spinet.gr/glossomatheia/programs/

Εσπερινό - Θέμα 2α
http://spinet.gr/glossomatheia/programs/viewtopic.php?f=39&t=670
Σελίδα 1 από 1

Συγγραφέας:  ΧΑΤΖΗΤΣΟΜΠΑΝΗΣ ΘΕΟΦΙΛΟΣ [ Δευτ 28 Ιούλ 2008 12:36 pm ]
Θέμα δημοσίευσης:  Εσπερινό - Θέμα 2α

Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΕΣΠΕΡΙΝΟ - ΜΑΙΟΣ 2008 - ΘΕΜΑ 2α
! ===============================================================================================
! Δίνεται το παρακάτω τμήμα αλγορίθμου:
!
! Χ <-- 2
! ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
!   ΑΝ Χ MOD 4 > 2 ΤΟΤΕ
!     Χ <-- Χ + 2
!   ΑΛΛΙΩΣ
!     Χ <-- Χ + 3
!   ΤΕΛΟΣ_ΑΝ
!   ΕΜΦΑΝΙΣΕ Χ
! ΜΕΧΡΙΣ_ΟΤΟΥ Χ > 15
!
! α. Ποιο είναι το πλήθος των επαναλήψεων που θα εκτελεστούν;
! β. Να γράψετε στο τετράδιό σας την τιμή της μεταβλητής Χ που θα εμφανιστεί σε κάθε επανάληψη.
! γ. Ποια είναι η τελική τιμή της μεταβλητής Χ;
!
! ===============================================================================================

ΠΡΟΓΡΑΜΜΑ  ESP_2008_05_2a
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : x
ΑΡΧΗ
  x <-- 2
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ x MOD 4 > 2 ΤΟΤΕ
      x <-- x + 2
    ΑΛΛΙΩΣ
      x <-- x + 3
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ x
  ΜΕΧΡΙΣ_ΟΤΟΥ x > 15

  ΓΡΑΨΕ 'Τελική τιμή του x =' , x

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

Σελίδα 1 από 1 Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/