Ασκησιολόγιο ΓλωσσοΜάθειας
http://spinet.gr/glossomatheia/programs/

Προσομοίωση - Θέμα 1γ
http://spinet.gr/glossomatheia/programs/viewtopic.php?f=39&t=666
Σελίδα 1 από 1

Συγγραφέας:  ΧΑΤΖΗΤΣΟΜΠΑΝΗΣ ΘΕΟΦΙΛΟΣ [ Παρ 25 Ιούλ 2008 10:35 pm ]
Θέμα δημοσίευσης:  Προσομοίωση - Θέμα 1γ

Syntax: [ Download ] [ Hide ]
! ===============================================================================================
! ΠΡΟΣΟΜΟΙΩΣΗ 2008 - ΘΕΜΑ 1Γ
! ================================================================================================
! Το παρακάτω τμήμα αλγορίθμου να μετατραπεί σε ισοδύναμο, χρησιμοποιώντας αποκλειστικά τη δομή
! Όσο... Επανάλαβε.
!
!    Σ <-- 0
!    Μ <-- 1000
!    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
!       ΔΙΑΒΑΣΕ αρ
!       Σ <-- Σ + αρ
!       M <-- M + 1
!    ΜΕΧΡΙΣ_ΟΤΟΥ (Σ < -100) ή ( Μ = 2008)
!    ΕΜΦΑΝΙΣΕ Σ , Μ
!
!================================================================================================

ΠΡΟΓΡΑΜΜΑ  PR_07_1C
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Σ , Μ , αρ
ΑΡΧΗ

! ΟΠΩΣ ΔΙΝΕΤΑΙ

  Σ <-- 0
  Μ <-- 1000
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ αρ
    Σ <-- Σ + αρ
    M <-- M + 1
  ΜΕΧΡΙΣ_ΟΤΟΥ (Σ < -100) ή ( Μ = 2008)        ! ΜΟΛΙΣ ΙΣΧΥΣΟΥΝ ΟΙ ΣΥΝΘΗΚΕΣ Η ΕΠΑΝΑΛΗΠΤΙΚΗ ΔΟΜΗ
  ΓΡΑΨΕ Σ , Μ                                             ! ΠΑΥΕΙ ΝΑ ΕΚΤΕΛΕΙΤΑΙ

! ΜΕΤΑ ΤΗΝ ΜΕΤΑΤΡΟΠΗ

  Σ <-- 0
  Μ <-- 1000
  ΟΣΟ (Σ >= -100) ΚΑΙ (Μ <> 2008) ΕΠΑΝΑΛΑΒΕ   ! ΟΙ ΣΥΝΘΗΚΕΣ ΕΙΝΑΙ ΑΝΑΠΟΔΕΣ ΜΕ ΑΥΤΕΣ ΤΟΥ ΑΡΧΙΚΟΥ
    ΔΙΑΒΑΣΕ αρ                                                ! ΔΙΟΤΙ ΟΣΟ ΙΣΧΥΟΥΝ Η ΕΠΑΝΑΛΗΠΤΙΚΗ ΔΟΜΗ ΕΚΤΕΛΕΙΤΑΙ
    Σ <-- Σ + αρ
    M <-- M + 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ Σ , Μ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 

Σελίδα 1 από 1 Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/