Ασκησιολόγιο ΓλωσσοΜάθειας
http://spinet.gr/glossomatheia/programs/

Προσομοίωση - Θέμα 1δ
http://spinet.gr/glossomatheia/programs/viewtopic.php?f=39&t=665
Σελίδα 1 από 1

Συγγραφέας:  ΧΑΤΖΗΤΣΟΜΠΑΝΗΣ ΘΕΟΦΙΛΟΣ [ Παρ 25 Ιούλ 2008 10:34 pm ]
Θέμα δημοσίευσης:  Προσομοίωση - Θέμα 1δ

Syntax: [ Download ] [ Hide ]
! ===========================================================================================
! ΠΡΟΣΟΜΟΙΩΣΗ 2008 - ΘΕΜΑ 1Δ
! ===========================================================================================
! Στο ακόλουθο τμήμα προγράμματος, να συμπληρώσετε το τμήμα δηλώσεων που έχει παραλειφθεί.
!
!  ΠΡΟΓΡΑΜΜΑ ΑΣΚΗΣΗ
!  …
!  ΑΡΧΗ
!    ΔΙΑΒΑΣΕ Β
!    X <-- 28
!    Κ <-- 13
!    ΟΣΟ Χ<> 0 ΕΠΑΝΑΛΑΒΕ
!       Κ <-- Κ - 2
!       ΑΝ Β = 'ΑΛΗΘΗΣ' ΤΟΤΕ
!          Υ <-- Κ MOD 2
!          L <-- K MOD Y
!       ΑΛΛΙΩΣ
!          R <-- K / 2
!          X <-- X + R
!       ΤΕΛΟΣ_ΑΝ
!       ΓΡΑΨΕ Χ , Κ
!   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!
!============================================================================================

ΠΡΟΓΡΑΜΜΑ  PR_07_1D
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: K , Y , L ! Οι μεταβλητές αυτές συνδέονται με την πράξη MOD γιαυτό είναι ακέραιες.
  ΠΡΑΓΜΑΤΙΚΕΣ: X , R  ! Η τιμή του Κ είναι 13, οπότε τα R ΚΑΙ Χ παίρνουν δεκαδικές τιμές.
  ΧΑΡΑΚΤΗΡΕΣ: B       ! Η τιμή του Β συγκρίνεται με το ΑΛΗΘΗΣ σε εισαγωγικά, άρα είναι αλφαριθμητικό
ΑΡΧΗ                  ! (αν το συγκρίναμε με το ΑΛΗΘΗΣ χωρίς εισαγωγικά θα το δηλώναμε ΛΟΓΙΚΗ μεταβλητή.

  ΔΙΑΒΑΣΕ B
  X <-- 28
  K <-- 13
  ΟΣΟ X <> 0 ΕΠΑΝΑΛΑΒΕ
    K <-- K - 2
    ΑΝ B = 'ΑΛΗΘΗΣ' ΤΟΤΕ
      Y <-- K MOD 2
      L <-- K MOD Y
    ΑΛΛΙΩΣ
      R <-- K / 2
      X <-- X + R
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ X , K
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

! ΠΑΡΑΤΗΡΗΣΗ : Το πρόγραμμα είναι λάθος γιατί το Χ ποτέ δε γίνεται μηδέν, οπότε η επαναληπτική δομή
!              είναι ατέρμων βρόχος (παραβιάζεται το κριτήριο της περατότητας).
 

Σελίδα 1 από 1 Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/