Ασκησιολόγιο ΓλωσσοΜάθειας
http://spinet.gr/glossomatheia/programs/

Προσομοίωση - Θέμα 2α
http://spinet.gr/glossomatheia/programs/viewtopic.php?f=39&t=662
Σελίδα 1 από 1

Συγγραφέας:  ΧΑΤΖΗΤΣΟΜΠΑΝΗΣ ΘΕΟΦΙΛΟΣ [ Παρ 25 Ιούλ 2008 10:31 pm ]
Θέμα δημοσίευσης:  Προσομοίωση - Θέμα 2α

Syntax: [ Download ] [ Hide ]
! ==================================================================
!  ΠΡΟΣΟΜΟΙΩΣΗ 2008 - ΘΕΜΑ 2Α
! ==================================================================
!  Να μετατρέψετε το παρακάτω διάγραμμα ροής σε μορφή ψευδοκώδικα.
! ==================================================================

ΠΡΟΓΡΑΜΜΑ PR_08_2Α
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : x , y
ΑΡΧΗ
  x <-- 1
  y <-- 0
  ΟΣΟ x <= 99 ΕΠΑΝΑΛΑΒΕ
    y <-- y + x
    x <-- x + 2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ y
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    y <-- y DIV 2
    ΓΡΑΨΕ y
  ΜΕΧΡΙΣ_ΟΤΟΥ y > 0
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Συνημμένα:
PR_2008_02.jpg
PR_2008_02.jpg [ 101.28 KiB | 2499 προβολές ]

Σελίδα 1 από 1 Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/