Τώρα είναι Δευτ 10 Αύγ 2020 05:56 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Προσομοίωση - Θέμα 2α
ΔημοσίευσηΔημοσιεύτηκε: Παρ 25 Ιούλ 2008 10:31 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ==================================================================
!  ΠΡΟΣΟΜΟΙΩΣΗ 2008 - ΘΕΜΑ 2Α
! ==================================================================
!  Να μετατρέψετε το παρακάτω διάγραμμα ροής σε μορφή ψευδοκώδικα.
! ==================================================================

ΠΡΟΓΡΑΜΜΑ PR_08_2Α
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : x , y
ΑΡΧΗ
  x <-- 1
  y <-- 0
  ΟΣΟ x <= 99 ΕΠΑΝΑΛΑΒΕ
    y <-- y + x
    x <-- x + 2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ y
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    y <-- y DIV 2
    ΓΡΑΨΕ y
  ΜΕΧΡΙΣ_ΟΤΟΥ y > 0
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Συνημμένα:
PR_2008_02.jpg
PR_2008_02.jpg [ 101.28 KiB | 2353 προβολές ]
Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters