Τώρα είναι Δευτ 21 Σεπ 2020 02:53 pm

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Προσομοίωση - Θέμα 2β
ΔημοσίευσηΔημοσιεύτηκε: Παρ 25 Ιούλ 2008 10:30 pm 
Χωρίς σύνδεση

Εγγραφή: Κυρ 12 Οκτ 2003 01:52 am
Δημοσιεύσεις: 189
Τοποθεσία: ΝΙΚΑΙΑ - ΠΕΙΡΑΙΑΣ
Syntax: [ Download ] [ Hide ]
! ====================================================================
!  ΠΡΟΣΟΜΟΙΩΣΗ 2008 - ΘΕΜΑ 2B
! ====================================================================
!  Δίνεται πίνακας ακεραίων Α με τις εξής τιμές : 3 , 1 , 6 , 15 , 12
!  και το ακόλουθο τμήμα αλγορίθμου:
!
!    κ <-- 0
!    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
!      flag <-- ψευδής
!      ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 4
!         ΑΝ Α[i] > Α[i+1] ΤΟΤΕ
!            προσ <-- Α[i]
!            Α[i] <-- Α[i+1]
!            Α[i+1] <-- προσ
!            flag <-- αληθής
!            κ <-- κ + 1
!         ΤΕΛΟΣ_ΑΝ
!      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!    ΜΕΧΡΙΣ_ΟΤΟΥ flag = ψευδής
!
!  α) Να γράψετε στο τετράδιο σας τις τιμές του πίνακα που θα προκύψουν
!     μετά την εκτέλεση του παραπάνω τμήματος αλγορίθμου.
!  β) Τι εκφράζει η τιμή της μεταβλητής κ;
!
! ====================================================================

ΠΡΟΓΡΑΜΜΑ PR_08_2B
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ : a[5] , προσ , κ , i
  ΛΟΓΙΚΕΣ : flag
ΑΡΧΗ
  a[1] <-- 3
  a[2] <-- 1
  a[3] <-- 6
  a[4] <-- 15
  a[5] <-- 12
  κ <-- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    flag <-- ψευδής
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 4
      ΑΝ a[i] > a[i+1] ΤΟΤΕ
        προσ <-- a[i]
        a[i] <-- a[i+1]
        a[i+1] <-- προσ
        flag <-- αληθής
        κ <-- κ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΕΧΡΙΣ_ΟΤΟΥ flag = ψευδής

  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 5
    ΓΡΑΨΕ a[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'Αριθμός εναλλαγής περιεχομένων θέσεων πίνακα κ =', κ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
 


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές σελίδων: website counters