Ασκησιολόγιο ΓλωσσοΜάθειας
http://spinet.gr/glossomatheia/programs/

Ημερήσιο - Θέμα 2β
http://spinet.gr/glossomatheia/programs/viewtopic.php?f=39&t=651
Σελίδα 1 από 1

Συγγραφέας:  SpiN [ Κυρ 15 Ιουν 2008 07:50 pm ]
Θέμα δημοσίευσης:  Ημερήσιο - Θέμα 2β

Να γράψετε στο τετράδιό σας τις τιμές της μεταβλητής pow που θα εμφανιστούν κατά την εκτέλεση του προγράμματος Α, αν ως τιμές εισόδου δοθούν οι αριθμοί:
x = 2, n = 3

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Α
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: x, n, m, pow, z
ΑΡΧΗ
  ΔΙΑΒΑΣΕ x,n
  m <-- n
  pow <-- 1
  z <--  x
  ΟΣΟ m > 0 ΕΠΑΝΑΛΑΒΕ
    ΟΣΟ (m MOD 2) = 0 ΕΠΑΝΑΛΑΒΕ
      m <-- m DIV 2
      z <-- z * z
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    m <--  m-1
    ΓΡΑΨΕ pow
    pow <-- pow * z
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ pow
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Α

Οι τιμές που θα εμφανιστούν είναι οι:
1
2
8

όπως αναλύεται και στην "Ανασκόπηση εκτέλεσης" παρακάτω (πλήκτρο F6 στη ΓλωσσοΜάθεια)...

Συνημμένα:
Σχόλια αρχείου: Ανασκόπηση εκτέλεσης
2008_imerisio_2b.png
2008_imerisio_2b.png [ 32.59 KiB | 2629 προβολές ]

Σελίδα 1 από 1 Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/