Τώρα είναι Δευτ 10 Αύγ 2020 05:34 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ημερήσιο - Θέμα 2β
ΔημοσίευσηΔημοσιεύτηκε: Κυρ 15 Ιουν 2008 07:50 pm 
Χωρίς σύνδεση
Διαχειριστής

Εγγραφή: Παρ 28 Φεβ 2003 06:10 pm
Δημοσιεύσεις: 84
Να γράψετε στο τετράδιό σας τις τιμές της μεταβλητής pow που θα εμφανιστούν κατά την εκτέλεση του προγράμματος Α, αν ως τιμές εισόδου δοθούν οι αριθμοί:
x = 2, n = 3

Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ Α
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: x, n, m, pow, z
ΑΡΧΗ
  ΔΙΑΒΑΣΕ x,n
  m <-- n
  pow <-- 1
  z <--  x
  ΟΣΟ m > 0 ΕΠΑΝΑΛΑΒΕ
    ΟΣΟ (m MOD 2) = 0 ΕΠΑΝΑΛΑΒΕ
      m <-- m DIV 2
      z <-- z * z
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    m <--  m-1
    ΓΡΑΨΕ pow
    pow <-- pow * z
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ pow
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Α

Οι τιμές που θα εμφανιστούν είναι οι:
1
2
8

όπως αναλύεται και στην "Ανασκόπηση εκτέλεσης" παρακάτω (πλήκτρο F6 στη ΓλωσσοΜάθεια)...


Συνημμένα:
Σχόλια αρχείου: Ανασκόπηση εκτέλεσης
2008_imerisio_2b.png
2008_imerisio_2b.png [ 32.59 KiB | 2493 προβολές ]
Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 1 Δημοσίευση ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 3 επισκέπτες


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
cron
Προβολές σελίδων: website counters