Τώρα είναι Τρί 21 Οκτ 2014 10:02 am

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 9 Δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 21 Ιαν 2006 09:51 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 21 Ιαν 2006 09:34 pm
Δημοσιεύσεις: 2
Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ πανελλαδικες
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: μπ,μγ,φπ,φγ,ππ,πγ,οπ,ογ,μγπ,μγγ,επ,εγ,βπμ,βπφ,βππ,βπο,βπμγ,βπε,βπ,μορια,απαντ
  ΛΟΓΙΚΕΣ: επαν
ΑΡΧΗ
  επαν <-- ΨΕΥΔΗΣ
  ΟΣΟ επαν=ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'δωσε τον προφορικο και μετα τον γραπτο βαθμο σου στα Μαθ/κα κατευθυνσης'
    ΔΙΑΒΑΣΕ μπ,μγ
    ΓΡΑΨΕ  'δωσε τον προφορικο και μετα τον γραπτο βαθμο σου στη φυσικη'
    ΔΙΑΒΑΣΕ φπ,φγ
    ΓΡΑΨΕ  'δωσε τον προφορικο και μετα τον γραπτο βαθμο σου στον Προγραμματισμο'
    ΔΙΑΒΑΣΕ ππ,πγ
    ΓΡΑΨΕ 'δωσε τον προφορικο και μετα τον γραπτο βαθμο σου στην οργανωση'
    ΔΙΑΒΑΣΕ οπ,ογ
    ΓΡΑΨΕ  'δωσε τον προφορικο και μετα τον γραπτο βαθμο σου στα Μαθ/κα γενικης'
    ΔΙΑΒΑΣΕ μγπ,μγγ
    ΓΡΑΨΕ  'δωσε τον προφορικο και μετα τον γραπτο βαθμο σου στην Εκθεση'
    ΔΙΑΒΑΣΕ επ,εγ
    ΑΝ μπ>μγ+2 ΤΟΤΕ
      μπ <-- μγ+2
    ΤΕΛΟΣ_ΑΝ
    ΑΝ φπ>φγ+2 ΤΟΤΕ
      φπ <-- φγ+2
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ππ>πγ+2 ΤΟΤΕ
      ππ <-- πγ+2
    ΤΕΛΟΣ_ΑΝ
    ΑΝ οπ>ογ+2 ΤΟΤΕ
      οπ <-- ογ+2
    ΤΕΛΟΣ_ΑΝ
    ΑΝ μγπ>μγγ+2 ΤΟΤΕ
      μγπ <-- μγγ+2
    ΤΕΛΟΣ_ΑΝ
    ΑΝ επ>εγ+2 ΤΟΤΕ
      επ <-- εγ+2
    ΤΕΛΟΣ_ΑΝ
    βπμ <-- (μπ*30/100)+(μγ*70/100)
    βπφ <-- (φπ*30/100)+(φγ*70/100)
    βππ <-- (ππ*30/100)+(πγ*70/100)
    βπο <-- (οπ*30/100)+(ογ*70/100)
    βπμγ <-- (μγπ*30/100)+(μγγ*70/100)
    βπε <-- (επ*30/100)+(εγ*70/100)
    βπ <-- (βπμ+βπφ+βππ+βπο+βπμγ+βπε)/6
    μορια <-- (βπ*8+βπμ*1.3+βπφ*0.7)*100
    ΓΡΑΨΕ 'τα μορια που συγκεντρωσε ο υποψηφιος ειναι', μορια
    ΓΡΑΨΕ 'θελεις νεο υπολογισμο μοριων?       1 για ναι και 2 για οχι'
    ΔΙΑΒΑΣΕ απαντ
    ΑΝ απαντ=2 ΤΟΤΕ
      επαν <-- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'καλα αποτελεσματα'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ πανελλαδικες
 


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 23 Ιαν 2006 10:24 pm 
Χωρίς σύνδεση

Εγγραφή: Σάβ 21 Ιαν 2006 09:34 pm
Δημοσιεύσεις: 2
********μια πιο ολοκληρομενη προσπαθεια για ολες τις κατευθυνσεις****






Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ  πανελλαδικες
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:πζ,γζ,πα,γα,πβ,γβ,πγ,γγ,πδ,γδ,πε,γε,πσ,γσ,βα,ββ,βγ,βδ,βε,βσ,βζ,βπ,μορια
  ΧΑΡΑΚΤΗΡΕΣ:κι,κ,ς,
ΑΡΧΗ
  κι <-- 'ν'
  πζ <-- 0
  γζ <-- 0
  ΟΣΟ κι='ν' ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ '***Γεια σου φιλε μου!***'
    ΓΡΑΨΕ 'Ποια κατευθυνση εχεις επιλεξει?'
    ΓΡΑΨΕ 'γράψε θ για θετικη, θρ για θεωριτικη και τ για τεχνολογικη'
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ κ
    ΜΕΧΡΙΣ_ΟΤΟΥ κ='θ' ή κ='θρ' ή κ='τ'
    ΑΝ κ='θ' ΤΟΤΕ
      ΓΡΑΨΕ 'εχεις επιλεξει το μαθημα "Αρχες Οικονομικης θεωριας"  ν ή ο'
      ΔΙΑΒΑΣΕ ς
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στα Μαθηματικα'
      ΔΙΑΒΑΣΕ πα
      ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στα Μαθηματικα'
      ΔΙΑΒΑΣΕ γα
      ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στην φυσικη'
      ΔΙΑΒΑΣΕ πβ
      ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στην φυσικη'
      ΔΙΑΒΑΣΕ γβ
      ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στην χημεια'
      ΔΙΑΒΑΣΕ πγ
      ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στην χημεια'
      ΔΙΑΒΑΣΕ γγ
      ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στην βιολογια'
      ΔΙΑΒΑΣΕ πδ
      ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στην βιολογια'
      ΔΙΑΒΑΣΕ γδ
      ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στην εκθεση'
      ΔΙΑΒΑΣΕ πε
      ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στην εκθεση'
      ΔΙΑΒΑΣΕ γε
      ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στο εκτο μαθημα'
      ΔΙΑΒΑΣΕ πσ
      ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στο εκτο μαθημα'
      ΔΙΑΒΑΣΕ γσ
      ΑΝ ς='ν' ΤΟΤΕ
        ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στην οικονομια'
        ΔΙΑΒΑΣΕ πζ
        ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στην οικονομια'
        ΔΙΑΒΑΣΕ γζ
      ΤΕΛΟΣ_ΑΝ

    ΑΛΛΙΩΣ_ΑΝ κ='τ' ΤΟΤΕ

      ΓΡΑΨΕ 'εχεις επιλεξει το μαθημα "Αρχες Οικονομικης θεωριας"  ν ή ο'
      ΔΙΑΒΑΣΕ ς
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στα Μαθηματικα'
      ΔΙΑΒΑΣΕ πα
      ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στα Μαθηματικα'
      ΔΙΑΒΑΣΕ γα
      ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στην φυσικη'
      ΔΙΑΒΑΣΕ πβ
      ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στην φυσικη'
      ΔΙΑΒΑΣΕ γβ
      ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στην πληροφορικη'
      ΔΙΑΒΑΣΕ πγ
      ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στην πληροφορικη'
      ΔΙΑΒΑΣΕ γγ
      ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στην διοικηση'
      ΔΙΑΒΑΣΕ πδ
      ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στην διοικηση'
      ΔΙΑΒΑΣΕ γδ
      ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στην εκθεση'
      ΔΙΑΒΑΣΕ πε
      ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στην εκθεση'
      ΔΙΑΒΑΣΕ γε
      ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στο εκτο μαθημα'
      ΔΙΑΒΑΣΕ πσ
      ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στο εκτο μαθημα'
      ΔΙΑΒΑΣΕ γσ
      ΑΝ ς='ν' ΤΟΤΕ
        ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στην οικονομια'
        ΔΙΑΒΑΣΕ πζ
        ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στην οικονομια'
        ΔΙΑΒΑΣΕ γζ
      ΤΕΛΟΣ_ΑΝ

    ΑΛΛΙΩΣ

      ΓΡΑΨΕ 'εχεις επιλεξει το μαθημα "Αρχες Οικονομικης θεωριας"  ν ή ο'
      ΔΙΑΒΑΣΕ ς
      ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
      ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στα αρχαια'
      ΔΙΑΒΑΣΕ πα
      ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στα αρχαια'
      ΔΙΑΒΑΣΕ γα
      ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στην ιστορια'
      ΔΙΑΒΑΣΕ πβ
      ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στην ιστορια'
      ΔΙΑΒΑΣΕ γβ
      ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στα κειμενα'
      ΔΙΑΒΑΣΕ πγ
      ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στα κειμενα'
      ΔΙΑΒΑΣΕ γγ
      ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στα λατινικα'
      ΔΙΑΒΑΣΕ πδ
      ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στα λατινικα'
      ΔΙΑΒΑΣΕ γδ
      ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στην εκθεση'
      ΔΙΑΒΑΣΕ πε
      ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στην εκθεση'
      ΔΙΑΒΑΣΕ γε
      ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στο εκτο μαθημα'
      ΔΙΑΒΑΣΕ πσ
      ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στο εκτο μαθημα'
      ΔΙΑΒΑΣΕ γσ
      ΑΝ ς='ν' ΤΟΤΕ
        ΓΡΑΨΕ 'δωσε τον προφορικο σου βαθμο στην οικονομια'
        ΔΙΑΒΑΣΕ πζ
        ΓΡΑΨΕ 'δωσε τον γραπτο σου βαθμο στην οικονομια'
        ΔΙΑΒΑΣΕ γζ
      ΤΕΛΟΣ_ΑΝ

    ΤΕΛΟΣ_ΑΝ
    ΚΑΘΑΡΙΣΕ_ΟΘΟΝΗ
    ΑΝ πα>γα+2 ΤΟΤΕ
      πα <-- γα+2
    ΤΕΛΟΣ_ΑΝ
    ΑΝ πβ>γβ+2 ΤΟΤΕ
      πβ <-- γβ+2
    ΤΕΛΟΣ_ΑΝ
    ΑΝ πγ>γγ+2 ΤΟΤΕ
      πγ <-- γγ+2
    ΤΕΛΟΣ_ΑΝ
    ΑΝ πδ>γδ+2 ΤΟΤΕ
      πδ <-- γδ+2
    ΤΕΛΟΣ_ΑΝ
    ΑΝ πε>γε+2 ΤΟΤΕ
      πε <-- γε+2
    ΤΕΛΟΣ_ΑΝ
    ΑΝ πσ>γσ+2 ΤΟΤΕ
      πσ <-- γσ+2
    ΤΕΛΟΣ_ΑΝ
    ΑΝ πζ>γζ+2 τότε
      πζ <-- γζ+2
    ΤΕΛΟΣ_ΑΝ
    βα <-- πα*30/100+γα*70/100
    ββ <-- πβ*30/100+γβ*70/100
    βγ <-- πγ*30/100+γγ*70/100
    βδ <-- πδ*30/100+γδ*70/100
    βε <-- πε*30/100+γε*70/100
    βσ <-- πσ*30/100+γσ*70/100
    ΑΝ ς='ν' ΤΟΤΕ
      βζ <-- πζ*30/100+γζ*70/100
      βπ <-- (βα+ββ+βγ+βδ+βε+βσ+βζ)/7
    ΑΛΛΙΩΣ_ΑΝ ς='ο' ΤΟΤΕ
      βπ <-- (βα+ββ+βγ+βδ+βε+βσ)/6
    ΤΕΛΟΣ_ΑΝ
    μορια <-- (βπ*8+βα*1.3+ββ*0.7)*100
    ΓΡΑΨΕ 'Τα μορια που συγκεντρωσες ειναι.............',μορια
    ΓΡΑΨΕ 'καλη προσπαθεια'
    ΓΡΑΨΕ
    ΓΡΑΨΕ
    ΓΡΑΨΕ
    ΓΡΑΨΕ
    ΓΡΑΨΕ 'θελεις να κανεις καινουργιο υπολογισμο μοριων?  ν ή ο'
    ΔΙΑΒΑΣΕ κι
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ 'καλα αποτελεσματα'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ πανελλαδικες
 


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Σάβ 08 Απρ 2006 12:31 am 
παραθετω και εγω ενα προγραμμα για τον υπολογισμο μοριων το οποιο καπου ''χανει'' περιπου 180 μορια και επισεις εχει ενα μικρο προβλημα στην εμφανιση αποτελεσματων. το συγκεκριμενο υπολογιζει για ολες τις κατευθυνσεις και ολα τα επιστημονικα πεδια
Syntax: [ Download ] [ Hide ]
!ΕΙΝΑΙ ΠΡΟΓΡΑΜΜΑ ΠΟΥ ΥΠΟΛΟΓΙΖΕΙ ΤΑ ΜΟΡΙΑ ΔΙΝΟΝΤΑΣ ΤΟΥΣ ΒΑΘΜΟΥΣ ΣΤΑ ΕΞΙ ΠΑΝΕΛΛΑΔΙΚΑ ΜΑΘΗΜΑΤΑ
!ΠΡΕΠΕΙ ΝΑ ΔΩΣΕΙΣ ΤΟΥΣ ΒΑΘΜΟΥΣ ΤΩΝ ΔΥΟ ΤΕΤΡΑΜΗΝΩΝ ΚΑΙ ΤΟΝ ΓΡΑΠΤΟ ΒΑΘΜΟ
ΠΡΟΓΡΑΜΜΑ ΥΠΟΛΟΓΙΣΜΟΣ_ΜΟΡΙΩΝ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ : ΒΑΘΜΟΙ[7,3],ΜΟ[7],ΠΒΑ[7],ΒΠ[7],Σ,ΜΟΤ,ΘΜΟΡΙΑ1,ΘΜΟΡΙΑ2,ΘΜΟΡΙΑ3,ΘΜΟΡΙΑ4,ΘΜΟΡΙΑ5
  ΠΡΑΓΜΑΤΙΚΕΣ : ΘΕΜΟΡΙΑ1,ΘΕΜΟΡΙΑ2,ΘΕΜΟΡΙΑ3,ΘΕΜΟΡΙΑ4,ΘΕΜΟΡΙΑ5
  ΠΡΑΓΜΑΤΙΚΕΣ : ΤΜΟΡΙΑ1,ΤΜΟΡΙΑ2,ΤΜΟΡΙΑ3,ΤΜΟΡΙΑ4,ΤΜΟΡΙΑ5
  ΑΚΕΡΑΙΕΣ : Ι,Ξ,Κ
  ΧΑΡΑΚΤΗΡΕΣ : ΚΑΤΕΥΘΥΝΣΗ,ΕΠΙΛΟΓΗΣ,ΓΕΝΙΚΗΣ
ΑΡΧΗ
  ΓΡΑΨΕ 'ΕΙΝΑΙ ΠΡΟΓΡΑΜΜΑ ΠΟΥ ΥΠΟΛΟΓΙΖΕΙ ΤΑ ΜΟΡΙΑ ΔΙΝΟΝΤΑΣ ΤΟΥΣ ΒΑΘΜΟΥΣ ΣΤΑ ΕΞΙ ΠΑΝΕΛΛΑΔΙΚΑ ΜΑΘΗΜΑΤΑ'
  ΓΡΑΨΕ 'ΠΡΕΠΕΙ ΝΑ ΔΩΣΕΙΣ ΤΟΥΣ ΒΑΘΜΟΥΣ ΤΩΝ ΔΥΟ ΤΕΤΡΑΜΗΝΩΝ ΚΑΙ ΤΟΝ ΓΡΑΠΤΟ ΒΑΘΜΟ'
  ΓΡΑΨΕ '---------------------------------------------------------------------'
  ΓΡΑΨΕ 'ΔΙΑΛΕΞΕ ΚΑΤΕΥΘΥΝΣΗ: ΓΙΑ ΘΕΩΡΗΤΙΚΗ ΠΑΤΗΣΕ 1, ΓΙΑ ΘΕΤΙΚΗ 2 ΚΑΙ ΤΕΧΝΟΛΟΓΙΚΗ 3'
  ΓΡΑΨΕ 'ΕΠΙΛΟΓΗ:'
  ΔΙΑΒΑΣΕ ΚΑΤΕΥΘΥΝΣΗ
  ΟΣΟ (ΚΑΤΕΥΘΥΝΣΗ<>'1') ΚΑΙ (ΚΑΤΕΥΘΥΝΣΗ<>'2') ΚΑΙ (ΚΑΤΕΥΘΥΝΣΗ<>'3') ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'ΔΩΣΕ ΔΕΚΤΑ ΣΤΟΙΧΕΙΑ:ΓΙΑ ΘΕΩΡΗΤΙΚΗ ΠΑΤΗΣΕ 1, ΓΙΑ ΘΕΤΙΚΗ 2 ΚΑΙ ΤΕΧΝΟΛΟΓΙΚΗ 3'
    ΔΙΑΒΑΣΕ ΚΑΤΕΥΘΥΝΣΗ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ '--------------------------------------------------------------------------'
  ΓΡΑΨΕ 'ΑΝ ΘΕΣ ΝΑ ΕΠΙΛΕΞΕΙΣ ΤΟ ΜΑΘΗΜΑ ΑΡΧΕΣ ΟΙΚΟΝΟΜΙΚΗΣ ΘΕΩΡΙΑΣ ΝΑ ΤΟ ΔΩΣΕΙΣ'
  ΓΡΑΨΕ 'ΠΑΝΕΛΛΑΔΙΚΑ ΤΟΤΕ ΠΑΤΗΣΕ "1" ΑΛΛΙΩΣ ΜΗΔΕΝ "0"'
  ΓΡΑΨΕ 'ΕΠΙΛΟΓΗ:'
  ΔΙΑΒΑΣΕ ΕΠΙΛΟΓΗΣ
  ΟΣΟ (ΕΠΙΛΟΓΗΣ<>'1') ΚΑΙ (ΕΠΙΛΟΓΗΣ<>'0') ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'ΔΩΣΕ ΔΕΚΤΑ ΣΤΟΙΧΕΙΑ:ΑΝ ΘΕΣ ΝΑ ΕΠΙΛΕΞΕΙΣ ΤΟ ΜΑΘΗΜΑ ΑΡΧΕΣ ΟΙΚΟΝΟΜΙΚΗΣ ΘΕΩΡΙΑΣ ΝΑ ΤΟ ΔΩΣΕΙΣ'
    ΓΡΑΨΕ 'ΠΑΝΕΛΛΑΔΙΚΑ ΤΟΤΕ ΠΑΤΗΣΕ "1" ΑΛΛΙΩΣ ΜΗΔΕΝ "0"'
    ΔΙΑΒΑΣΕ ΕΠΙΛΟΓΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ '--------------------------------------------'
  ΓΡΑΨΕ 'ΑΝ ΤΟ ΜΑΘΗΜΑ ΓΕΝΙΚΗΣ ΠΟΥ ΔΙΑΛΕΓΕΙΣ ΕΙΝΑΙ Η ΙΣΤΟΡΙΑ ΤΟΤΕ ΠΑΤΗΣΕ "1"'
  ΓΡΑΨΕ ''
  ΓΡΑΨΕ 'ΑΝ ΕΙΝΑΙ ΒΙΟΛΟΓΙΑ ΤΟΤΕ ΠΑΤΗΣΕ "2"'
  ΓΡΑΨΕ ''
  ΓΡΑΨΕ 'ΚΑΙ ΑΝ ΕΙΝΑΙ ΜΑΘΗΜΑΤΙΚΑ ΤΟΤΕ ΠΑΤΗΣΕ "3"'
  ΓΡΑΨΕ ''
  ΓΡΑΨΕ 'ΚΑΙ ΑΝ ΕΙΝΑΙ ΦΥΣΙΚΗ ΤΟΤΕ ΠΑΤΗΣΕ "4"'
  ΓΡΑΨΕ ''
  ΓΡΑΨΕ 'ΕΠΙΛΟΓΗ:'
  ΔΙΑΒΑΣΕ ΓΕΝΙΚΗΣ
  ΟΣΟ (ΓΕΝΙΚΗΣ<>'1') ΚΑΙ (ΓΕΝΙΚΗΣ<>'2') ΚΑΙ (ΓΕΝΙΚΗΣ<>'3') ΚΑΙ (ΓΕΝΙΚΗΣ<>'4') ΕΠΑΝΑΛΑΒΕ
    ΓΡΑΨΕ 'ΔΩΣΕ ΔΕΚΤΑ ΣΤΟΙΧΕΙΑ:'
    ΓΡΑΨΕ 'ΑΝ ΤΟ ΜΑΘΗΜΑ ΓΕΝΙΚΗΣ ΠΟΥ ΔΙΑΛΕΓΕΙΣ ΕΙΝΑΙ Η ΙΣΤΟΡΙΑ ΤΟΤΕ ΠΑΤΗΣΕ "1"'
    ΓΡΑΨΕ 'ΑΝ ΕΙΝΑΙ ΒΙΟΛΟΓΙΑ ΤΟΤΕ ΠΑΤΗΣΕ "2"'
    ΓΡΑΨΕ 'ΚΑΙ ΑΝ ΕΙΝΑΙ ΜΑΘΗΜΑΤΙΚΑ ΤΟΤΕ ΠΑΤΗΣΕ "3"'
    ΓΡΑΨΕ 'ΚΑΙ ΑΝ ΕΙΝΑΙ ΦΥΣΙΚΗ ΤΟΤΕ ΠΑΤΗΣΕ "4"'
    ΔΙΑΒΑΣΕ ΓΕΝΙΚΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ ΕΠΙΛΟΓΗΣ='1' ΤΟΤΕ
    Κ <-- 7
  ΑΛΛΙΩΣ
    Κ <-- 6
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'ΑΝ ΘΕΛΕΙΣ ΝΑ ΔΩΣΕΙΣ ΒΑΘΜΟ ΔΕΚΑΔΙΚΟ ΠΡΕΠΕΙ ΝΑ ΒΑΛΕΙ ΤΕΛΕΙΑ(.) ΚΑΙ ΟΧΙ ΚΟΜΜΑ(,) Π.Χ "18.3"'
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Κ
    ΓΙΑ Ξ ΑΠΟ 1 ΜΕΧΡΙ 3
      ΑΝ (Ι<3) ΚΑΙ (Ξ<3) ΤΟΤΕ
        ΓΡΑΨΕ ''
        ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΝ ΒΑΘΜΟ ΤΟΥ ',Ξ,'ου ΤΕΤΡΑΜΗΝΟΥ ΣΤΟ ',Ι,'ο ΜΑΘΗΜΑ ΓΕΝΙΚΗΣ ΠΑΙΔΕΙΑΣ'
        ΓΡΑΨΕ '(ΠΡΩΤΟ ΜΑΘΗΜΑ ΝΑ ΘΕΩΡΗΣΕΙΣ ΤΗΝ ΕΚΘΕΣΗ ΚΑΙ ΔΕΥΤΕΡΟ ΑΥΤΟ ΠΟΥ ΕΠΕΛΕΞΕΣ ΠΑΡΑΠΑΝΩ)'
        ΔΙΑΒΑΣΕ ΒΑΘΜΟΙ[Ι,Ξ]
        ΟΣΟ (ΒΑΘΜΟΙ[Ι,Ξ]<0) Η (ΒΑΘΜΟΙ[Ι,Ξ]>21) ΕΠΑΝΑΛΑΒΕ
          ΓΡΑΨΕ 'ΔΩΣΕ ΔΕΚΤΕΣ ΤΙΜΕΣ: 0 < ΒΑΘΜΟΣ <= 20'
          ΔΙΑΒΑΣΕ ΒΑΘΜΟΙ[Ι,Ξ]
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΛΛΙΩΣ_ΑΝ (Ι<3) ΚΑΙ (Ξ=3) ΤΟΤΕ
        ΓΡΑΨΕ ''
        ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΝ ΒΑΘΜΟ ΓΡΑΠΤΟΥ ΣΤΟ ',Ι,'ο ΜΑΘΗΜΑ ΓΕΝΙΚΗΣ ΠΑΙΔΕΙΑΣ'
        ΔΙΑΒΑΣΕ ΒΑΘΜΟΙ[Ι,Ξ]
        ΟΣΟ (ΒΑΘΜΟΙ[Ι,Ξ]<0) Η (ΒΑΘΜΟΙ[Ι,Ξ]>21) ΕΠΑΝΑΛΑΒΕ
          ΓΡΑΨΕ 'ΔΩΣΕ ΔΕΚΤΕΣ ΤΙΜΕΣ: 0 < ΒΑΘΜΟΣ <= 20'
          ΔΙΑΒΑΣΕ ΒΑΘΜΟΙ[Ι,Ξ]
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΛΛΙΩΣ_ΑΝ (Ι=3) ΚΑΙ (Ξ<3) ΤΟΤΕ
        ΓΡΑΨΕ ''
        ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΝ ΒΑΘΜΟ ΤΟΥ ',Ξ,'ου ΤΕΤΡΑΜΗΝΟΥ ΣΤΟ ΜΑΘΗΜΑ ΚΑΤΕΥΘΥΝΣΗΣ'
        ΓΡΑΨΕ '(ΓΙΑ ΘΕΤΙΚΗ, ΤΕΧΝΟΛΟΓΙΚΗ) ΜΑΘΗΜΑΤΙΚΑ (ΓΙΑ ΘΕΩΡΗΤΙΚΗ) ΑΡΧΑΙΑ'
        ΔΙΑΒΑΣΕ ΒΑΘΜΟΙ[Ι,Ξ]
        ΟΣΟ (ΒΑΘΜΟΙ[Ι,Ξ]<0) Η (ΒΑΘΜΟΙ[Ι,Ξ]>21) ΕΠΑΝΑΛΑΒΕ
          ΓΡΑΨΕ 'ΔΩΣΕ ΔΕΚΤΕΣ ΤΙΜΕΣ: 0 < ΒΑΘΜΟΣ <= 20'
          ΔΙΑΒΑΣΕ ΒΑΘΜΟΙ[Ι,Ξ]
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΛΛΙΩΣ_ΑΝ (Ι=3) ΚΑΙ (Ξ=3) ΤΟΤΕ
        ΓΡΑΨΕ ''
        ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΝ ΒΑΘΜΟ ΓΡΑΠΤΟΥ ΣΤΟ ΜΑΘΗΜΑ ΚΑΤΕΥΘΥΝΣΗΣ'
        ΓΡΑΨΕ '(ΓΙΑ ΘΕΤΙΚΗ, ΤΕΧΝΟΛΟΓΙΚΗ) ΜΑΘΗΜΑΤΙΚΑ (ΓΙΑ ΘΕΩΡΗΤΙΚΗ) ΑΡΧΑΙΑ'
        ΔΙΑΒΑΣΕ ΒΑΘΜΟΙ[Ι,Ξ]
        ΟΣΟ (ΒΑΘΜΟΙ[Ι,Ξ]<0) Η (ΒΑΘΜΟΙ[Ι,Ξ]>21) ΕΠΑΝΑΛΑΒΕ
          ΓΡΑΨΕ 'ΔΩΣΕ ΔΕΚΤΕΣ ΤΙΜΕΣ: 0 < ΒΑΘΜΟΣ <= 20'
          ΔΙΑΒΑΣΕ ΒΑΘΜΟΙ[Ι,Ξ]
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΛΛΙΩΣ_ΑΝ (Ι=4) ΚΑΙ (Ξ<3) ΤΟΤΕ
        ΓΡΑΨΕ ''
        ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΝ ΒΑΘΜΟ ΤΟΥ ',Ξ,'ου ΤΕΤΡΑΜΗΝΟΥ ΣΤΟ ΜΑΘΗΜΑ ΚΑΤΕΥΘΥΝΣΗΣ'
        ΓΡΑΨΕ '(ΓΙΑ ΘΕΤΙΚΗ, ΤΕΧΝΟΛΟΓΙΚΗ) ΦΥΣΙΚΗ (ΓΙΑ ΘΕΩΡΗΤΙΚΗ) ΙΣΤΟΡΙΑ'
        ΔΙΑΒΑΣΕ ΒΑΘΜΟΙ[Ι,Ξ]
        ΟΣΟ (ΒΑΘΜΟΙ[Ι,Ξ]<0) Η (ΒΑΘΜΟΙ[Ι,Ξ]>21) ΕΠΑΝΑΛΑΒΕ
          ΓΡΑΨΕ 'ΔΩΣΕ ΔΕΚΤΕΣ ΤΙΜΕΣ: 0 < ΒΑΘΜΟΣ <= 20'
          ΔΙΑΒΑΣΕ ΒΑΘΜΟΙ[Ι,Ξ]
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΛΛΙΩΣ_ΑΝ (Ι=4) ΚΑΙ (Ξ=3) ΤΟΤΕ
        ΓΡΑΨΕ ''
        ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΝ ΒΑΘΜΟ ΓΡΑΠΤΟΥ ΣΤΟ ΜΑΘΗΜΑ ΚΑΤΕΥΘΥΝΣΗΣ'
        ΓΡΑΨΕ '(ΓΙΑ ΘΕΤΙΚΗ, ΤΕΧΝΟΛΟΓΙΚΗ) ΦΥΣΙΚΗ (ΓΙΑ ΘΕΩΡΗΤΙΚΗ) ΙΣΤΟΡΙΑ'
        ΔΙΑΒΑΣΕ ΒΑΘΜΟΙ[Ι,Ξ]
        ΟΣΟ (ΒΑΘΜΟΙ[Ι,Ξ]<0) Η (ΒΑΘΜΟΙ[Ι,Ξ]>21) ΕΠΑΝΑΛΑΒΕ
          ΓΡΑΨΕ 'ΔΩΣΕ ΔΕΚΤΕΣ ΤΙΜΕΣ: 0 < ΒΑΘΜΟΣ <= 20'
          ΔΙΑΒΑΣΕ ΒΑΘΜΟΙ[Ι,Ξ]
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΛΛΙΩΣ_ΑΝ (Ι<7) ΚΑΙ (Ξ<3) ΤΟΤΕ
        ΓΡΑΨΕ ''
        ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΝ ΒΑΘΜΟ ΤΟΥ ',Ξ,'ου ΤΕΤΡΑΜΗΝΟΥ ΣΤΟ ΑΛΛΟ ΜΑΘΗΜΑ ΚΑΤΕΥΘΥΝΣΗΣ'
        ΓΡΑΨΕ '(ΓΙΑ ΘΕΤΙΚΗ ΠΡΩΤΑ ΒΙΟΛΟΓΙΑ)'
        ΔΙΑΒΑΣΕ ΒΑΘΜΟΙ[Ι,Ξ]
        ΟΣΟ (ΒΑΘΜΟΙ[Ι,Ξ]<0) Η (ΒΑΘΜΟΙ[Ι,Ξ]>21) ΕΠΑΝΑΛΑΒΕ
          ΓΡΑΨΕ 'ΔΩΣΕ ΔΕΚΤΕΣ ΤΙΜΕΣ: 0 < ΒΑΘΜΟΣ <= 20'
          ΔΙΑΒΑΣΕ ΒΑΘΜΟΙ[Ι,Ξ]
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΛΛΙΩΣ_ΑΝ (Ι<7) ΚΑΙ (Ξ=3) ΤΟΤΕ
        ΓΡΑΨΕ ''
        ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΝ ΒΑΘΜΟ ΓΡΑΠΤΟΥ ΣΤΟ ΑΛΛΟ ΜΑΘΗΜΑ ΚΑΤΕΥΘΥΝΣΗΣ'
        ΓΡΑΨΕ '(ΓΙΑ ΘΕΤΙΚΗ ΠΡΩΤΑ ΒΙΟΛΟΓΙΑ)'
        ΔΙΑΒΑΣΕ ΒΑΘΜΟΙ[Ι,Ξ]
        ΟΣΟ (ΒΑΘΜΟΙ[Ι,Ξ]<0) Η (ΒΑΘΜΟΙ[Ι,Ξ]>21) ΕΠΑΝΑΛΑΒΕ
          ΓΡΑΨΕ 'ΔΩΣΕ ΔΕΚΤΕΣ ΤΙΜΕΣ: 0 < ΒΑΘΜΟΣ <= 20'
          ΔΙΑΒΑΣΕ ΒΑΘΜΟΙ[Ι,Ξ]
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΛΛΙΩΣ_ΑΝ (Ι=7) ΚΑΙ (Ξ<3) ΤΟΤΕ
        ΓΡΑΨΕ ''
        ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΝ ΒΑΘΜΟ ΤΟΥ ',Ξ,'ου ΤΕΤΡΑΜΗΝΟΥ ΣΤΟ ΜΑΘΗΜΑ ΕΠΙΛΟΓΗΣ ΑΡΧΕΣ ΟΙΚΟΝΟΜΙΚΗΣ ΘΕΩΡΙΑΣ'
        ΔΙΑΒΑΣΕ ΒΑΘΜΟΙ[Ι,Ξ]
        ΟΣΟ (ΒΑΘΜΟΙ[Ι,Ξ]<0) Η (ΒΑΘΜΟΙ[Ι,Ξ]>21) ΕΠΑΝΑΛΑΒΕ
          ΓΡΑΨΕ 'ΔΩΣΕ ΔΕΚΤΕΣ ΤΙΜΕΣ: 0 < ΒΑΘΜΟΣ <= 20'
          ΔΙΑΒΑΣΕ ΒΑΘΜΟΙ[Ι,Ξ]
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΛΛΙΩΣ
        ΓΡΑΨΕ ''
        ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΝ ΒΑΘΜΟ ΓΡΑΠΤΟΥ ΣΤΟ ΜΑΘΗΜΑ ΕΠΙΛΟΓΗΣ ΑΡΧΕΣ ΟΙΚΟΝΟΜΙΚΗΣ ΘΕΩΡΙΑΣ'
        ΔΙΑΒΑΣΕ ΒΑΘΜΟΙ[Ι,Ξ]
        ΟΣΟ (ΒΑΘΜΟΙ[Ι,Ξ]<0) Η (ΒΑΘΜΟΙ[Ι,Ξ]>21) ΕΠΑΝΑΛΑΒΕ
          ΓΡΑΨΕ 'ΔΩΣΕ ΔΕΚΤΕΣ ΤΙΜΕΣ: 0 < ΒΑΘΜΟΣ <= 20'
          ΔΙΑΒΑΣΕ ΒΑΘΜΟΙ[Ι,Ξ]
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Κ
    ΜΟ[Ι] <-- 0
    ΓΙΑ Ξ ΑΠΟ 1 ΜΕΧΡΙ 2
      ΜΟ[Ι] <-- ΜΟ[Ι]+ΒΑΘΜΟΙ[Ι,Ξ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Κ
    ΜΟ[Ι] <-- ΜΟ[Ι]/2
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Κ
    ΑΝ (ΜΟ[Ι]>ΒΑΘΜΟΙ[Ι,3]+2) ΤΟΤΕ
      ΠΒΑ[Ι] <-- ΒΑΘΜΟΙ[Ι,3]+2
    ΑΛΛΙΩΣ_ΑΝ (ΜΟ[Ι]=ΒΑΘΜΟΙ[Ι,3]) ΤΟΤΕ
      ΠΒΑ[Ι] <-- ΜΟ[Ι]
    ΑΛΛΙΩΣ_ΑΝ (ΜΟ[Ι]<ΒΑΘΜΟΙ[Ι,3]-2) ΤΟΤΕ
      ΠΒΑ[Ι] <-- ΒΑΘΜΟΙ[Ι,3]-2
    ΑΛΛΙΩΣ
      ΠΒΑ[Ι] <-- ΜΟ[Ι]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Κ
    ΒΠ[Ι] <-- 0
    ΒΠ[Ι] <-- ((0.3)*ΠΒΑ[Ι])+((0.7)*ΒΑΘΜΟΙ[Ι,3])
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Σ <-- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Κ
    Σ <-- Σ + ΒΠ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΜΟΤ <-- Σ/Κ
  ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='1') ΚΑΙ (ΓΕΝΙΚΗΣ='1') ΚΑΙ (ΕΠΙΛΟΓΗΣ='0') ΤΟΤΕ
    ΘΜΟΡΙΑ1 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[3,3]*0.13)+(ΒΑΘΜΟΙ[4,3]*0.07)
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='1') ΚΑΙ (ΓΕΝΙΚΗΣ='1') ΚΑΙ (ΕΠΙΛΟΓΗΣ='1') ΤΟΤΕ
    ΘΜΟΡΙΑ1 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[3,3]*0.13)+(ΒΑΘΜΟΙ[4,3]*0.07)
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='1') ΚΑΙ (ΓΕΝΙΚΗΣ='2') ΚΑΙ (ΕΠΙΛΟΓΗΣ='0') ΤΟΤΕ
    ΘΜΟΡΙΑ3 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[1,3]*0.04)+(ΒΑΘΜΟΙ[2,3]*0.09)
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='1') ΚΑΙ (ΓΕΝΙΚΗΣ='2') ΚΑΙ (ΕΠΙΛΟΓΗΣ='1') ΤΟΤΕ
    ΘΜΟΡΙΑ3 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[1,3]*0.04)+(ΒΑΘΜΟΙ[2,3]*0.09)
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='1') ΚΑΙ (ΓΕΝΙΚΗΣ='3') ΚΑΙ (ΕΠΙΛΟΓΗΣ='0') ΤΟΤΕ
    ΘΜΟΡΙΑ2 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[1,3]*0.04)+(ΒΑΘΜΟΙ[2,3]*0.09)
    ΘΜΟΡΙΑ4 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[1,3]*0.04)+(ΒΑΘΜΟΙ[2,3]*0.09)
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='1') ΚΑΙ (ΓΕΝΙΚΗΣ='3') ΚΑΙ (ΕΠΙΛΟΓΗΣ='1') ΤΟΤΕ
    ΘΜΟΡΙΑ5 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[7,3]*0.13)+(ΒΑΘΜΟΙ[2,3]*0.07)
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='2') ΚΑΙ (ΓΕΝΙΚΗΣ='1') ΚΑΙ (ΕΠΙΛΟΓΗΣ='0') ΤΟΤΕ
    ΘΕΜΟΡΙΑ1 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[1,3]*0.04)+(ΒΑΘΜΟΙ[2,3]*0.09)
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='2') ΚΑΙ (ΓΕΝΙΚΗΣ='1') ΚΑΙ (ΕΠΙΛΟΓΗΣ='1') ΤΟΤΕ
    ΘΕΜΟΡΙΑ1 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[1,3]*0.04)+(ΒΑΘΜΟΙ[2,3]*0.09)
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='2') ΚΑΙ ((ΓΕΝΙΚΗΣ='1') Η (ΓΕΝΙΚΗΣ='2') Η (ΓΕΝΙΚΗΣ='3')) ΚΑΙ (ΕΠΙΛΟΓΗΣ='0') ΤΟΤΕ
    ΘΕΜΟΡΙΑ2 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[3,3]*0.13)+(ΒΑΘΜΟΙ[4,3]*0.07)
    ΘΕΜΟΡΙΑ4 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[3,3]*0.13)+(ΒΑΘΜΟΙ[4,3]*0.07)
    ΘΕΜΟΡΙΑ3 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[5,3]*0.13)+(ΒΑΘΜΟΙ[6,3]*0.07)
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='2') ΚΑΙ ((ΓΕΝΙΚΗΣ='1') Η (ΓΕΝΙΚΗΣ='2')) ΚΑΙ (ΕΠΙΛΟΓΗΣ='1') ΤΟΤΕ
    ΘΕΜΟΡΙΑ2 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[3,3]*0.13)+(ΒΑΘΜΟΙ[4,3]*0.07)
    ΘΕΜΟΡΙΑ4 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[3,3]*0.13)+(ΒΑΘΜΟΙ[4,3]*0.07)
    ΘΕΜΟΡΙΑ3 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[5,3]*0.13)+(ΒΑΘΜΟΙ[6,3]*0.07)
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='2') ΚΑΙ (ΓΕΝΙΚΗΣ='3') ΚΑΙ (ΕΠΙΛΟΓΗΣ='1') ΤΟΤΕ
    ΘΕΜΟΡΙΑ5 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[7,3]*0.13)+(ΒΑΘΜΟΙ[2,3]*0.07)
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='3') ΚΑΙ (ΓΕΝΙΚΗΣ='1') ΚΑΙ (ΕΠΙΛΟΓΗΣ='0') ΤΟΤΕ
    ΤΜΟΡΙΑ1 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[1,3]*0.04)+(ΒΑΘΜΟΙ[2,3]*0.09)
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='3') ΚΑΙ (ΓΕΝΙΚΗΣ='1') ΚΑΙ (ΕΠΙΛΟΓΗΣ='1') ΤΟΤΕ
    ΤΜΟΡΙΑ1 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[1,3]*0.04)+(ΒΑΘΜΟΙ[2,3]*0.09)
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='3') ΚΑΙ ((ΓΕΝΙΚΗΣ='1') Η (ΓΕΝΙΚΗΣ='2') Η (ΓΕΝΙΚΗΣ='3')) ΚΑΙ (ΕΠΙΛΟΓΗΣ='0') ΤΟΤΕ
    ΤΜΟΡΙΑ2 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[3,3]*0.13)+(ΒΑΘΜΟΙ[4,3]*0.07)
    ΤΜΟΡΙΑ4 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[3,3]*0.13)+(ΒΑΘΜΟΙ[4,3]*0.07)
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='3') ΚΑΙ ((ΓΕΝΙΚΗΣ='1') Η (ΓΕΝΙΚΗΣ='2') Η (ΓΕΝΙΚΗΣ='3')) ΚΑΙ (ΕΠΙΛΟΓΗΣ='1') ΤΟΤΕ
    ΤΜΟΡΙΑ2 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[3,3]*0.13)+(ΒΑΘΜΟΙ[4,3]*0.07)
    ΤΜΟΡΙΑ4 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[3,3]*0.13)+(ΒΑΘΜΟΙ[4,3]*0.07)
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='3') ΚΑΙ (ΓΕΝΙΚΗΣ='2') ΚΑΙ (ΕΠΙΛΟΓΗΣ='0') ΤΟΤΕ
    ΤΜΟΡΙΑ3 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[1,3]*0.04)+(ΒΑΘΜΟΙ[2,3]*0.09)
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='3') ΚΑΙ (ΓΕΝΙΚΗΣ='2') ΚΑΙ (ΕΠΙΛΟΓΗΣ='1') ΤΟΤΕ
    ΤΜΟΡΙΑ3 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[1,3]*0.04)+(ΒΑΘΜΟΙ[2,3]*0.09)
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='3') ΚΑΙ (ΓΕΝΙΚΗΣ='3') ΚΑΙ (ΕΠΙΛΟΓΗΣ='1') ΤΟΤΕ
    ΤΜΟΡΙΑ5 <-- (ΜΟΤ*0.8)+(ΒΑΘΜΟΙ[7,3]*0.13)+(ΒΑΘΜΟΙ[2,3]*0.07)
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ '-------------------------------'
  ΑΝ ΚΑΤΕΥΘΥΝΣΗ='1' ΤΟΤΕ
    ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΚΑΤΕΥΘΥΝΣΗ: ΘΕΩΡΗΤΙΚΗ'
  ΑΛΛΙΩΣ_ΑΝ ΚΑΤΕΥΘΥΝΣΗ='2' ΤΟΤΕ
    ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΚΑΤΕΥΘΥΝΣΗ: ΘΕΤΙΚΗ'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΚΑΤΕΥΘΥΝΣΗ: ΤΕΧΝΟΛΟΓΙΚΗ'
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ ''
  ΓΡΑΨΕ '----------------------------------'
  ΑΝ ΕΠΙΛΟΓΗΣ='0' ΤΟΤΕ
    ΓΡΑΨΕ 'ΔΕΝ ΕΠΕΛΕΞΕΣ ΝΑ ΔΩΣΕΙΣ ΠΑΝΕΛΛΑΔΙΚΑ ΤΟ ΜΑΘΗΜΑ ΑΡΧΕΣ ΟΙΚΟΝΟΜΙΚΗΣ ΘΕΩΡΙΑΣ'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'ΕΠΕΛΕΞΕΣ ΝΑ ΔΩΣΕΙΣ ΠΑΝΕΛΛΑΔΙΚΑ ΤΟ ΜΑΘΗΜΑ ΑΡΧΕΣ ΟΙΚΟΝΟΜΙΚΗΣ ΘΕΩΡΙΑΣ'
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ '------------------------------------------------------------------------'
  ΓΡΑΨΕ ''
  ΑΝ ΓΕΝΙΚΗΣ='1' ΤΟΤΕ
    ΓΡΑΨΕ 'ΩΣ ΔΕΥΤΕΡΟ ΜΑΘΗΜΑ ΓΕΝΙΚΗΣ ΠΑΙΔΕΙΑΣ ΕΠΕΛΕΞΕΣ ΤΗΝ ΙΣΤΟΡΙΑ'
  ΑΛΛΙΩΣ_ΑΝ ΓΕΝΙΚΗΣ='2' ΤΟΤΕ
    ΓΡΑΨΕ 'ΩΣ ΔΕΥΤΕΡΟ ΜΑΘΗΜΑ ΓΕΝΙΚΗΣ ΠΑΙΔΕΙΑΣ ΕΠΕΛΕΞΕΣ ΤΗΝ ΒΙΟΛΟΓΙΑ'
  ΑΛΛΙΩΣ_ΑΝ ΓΕΝΙΚΗΣ='3' ΤΟΤΕ
    ΓΡΑΨΕ 'ΩΣ ΔΕΥΤΕΡΟ ΜΑΘΗΜΑ ΓΕΝΙΚΗΣ ΠΑΙΔΕΙΑΣ ΕΠΕΛΕΞΕΣ ΤΑ ΜΑΘΗΜΑΤΙΚΑ'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'ΩΣ ΔΕΥΤΕΡΟ ΜΑΘΗΜΑ ΓΕΝΙΚΗΣ ΠΑΙΔΕΙΑΣ ΕΠΕΛΕΞΕΣ ΤΗ ΦΥΣΙΚΗ'
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ '-----------------------------------------------------------'
  ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='1') ΚΑΙ (ΓΕΝΙΚΗΣ='1') ΤΟΤΕ
    ΓΡΑΨΕ 'ΣΤΟ 1ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΘΜΟΡΙΑ1*1000,' ΜΟΡΙΑ'
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='1') ΚΑΙ (ΓΕΝΙΚΗΣ='3') ΤΟΤΕ
    ΓΡΑΨΕ 'ΣΤΟ 2ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΘΜΟΡΙΑ2*1000,' ΜΟΡΙΑ'
    ΓΡΑΨΕ 'ΣΤΟ 4ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΘΜΟΡΙΑ4*1000,' ΜΟΡΙΑ'
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='1') ΚΑΙ (ΓΕΝΙΚΗΣ='2') ΤΟΤΕ
    ΓΡΑΨΕ 'ΣΤΟ 3ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΘΜΟΡΙΑ3*1000,' ΜΟΡΙΑ'
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='1') ΚΑΙ (ΓΕΝΙΚΗΣ='3') ΚΑΙ (ΕΠΙΛΟΓΗΣ='1') ΤΟΤΕ
    ΓΡΑΨΕ 'ΣΤΟ 2ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΘΜΟΡΙΑ2*1000,' ΜΟΡΙΑ'
    ΓΡΑΨΕ 'ΣΤΟ 4ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΘΜΟΡΙΑ4*1000,' ΜΟΡΙΑ'
    ΓΡΑΨΕ 'ΣΤΟ 5ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΘΜΟΡΙΑ5*1000,' ΜΟΡΙΑ'
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='2') ΚΑΙ (ΓΕΝΙΚΗΣ='1') ΤΟΤΕ
    ΓΡΑΨΕ 'ΣΤΟ 1ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΘΕΜΟΡΙΑ1*1000,'ΜΟΡΙΑ'
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='2') ΚΑΙ ((ΓΕΝΙΚΗΣ='2') Η (ΓΕΝΙΚΗΣ='3') Η (ΓΕΝΙΚΗΣ='4')) ΤΟΤΕ
    ΓΡΑΨΕ 'ΣΤΟ 2ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΘΕΜΟΡΙΑ2*1000,' ΜΟΡΙΑ'
    ΓΡΑΨΕ 'ΣΤΟ 3ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΘΕΜΟΡΙΑ3*1000,' ΜΟΡΙΑ'
    ΓΡΑΨΕ 'ΣΤΟ 4ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΘΕΜΟΡΙΑ4*1000,' ΜΟΡΙΑ'
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='2') ΚΑΙ (ΓΕΝΙΚΗΣ='3') ΚΑΙ (ΕΠΙΛΟΓΗΣ='1') ΤΟΤΕ
    ΓΡΑΨΕ 'ΣΤΟ 2ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΘΕΜΟΡΙΑ2*1000,' ΜΟΡΙΑ'
    ΓΡΑΨΕ 'ΣΤΟ 3ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΘΕΜΟΡΙΑ3*1000,' ΜΟΡΙΑ'
    ΓΡΑΨΕ 'ΣΤΟ 4ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΘΕΜΟΡΙΑ4*1000,' ΜΟΡΙΑ'
    ΓΡΑΨΕ 'ΣΤΟ 5ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΘΕΜΟΡΙΑ5*1000,' ΜΟΡΙΑ'
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='3') ΚΑΙ (ΓΕΝΙΚΗΣ='1') ΤΟΤΕ
    ΓΡΑΨΕ 'ΣΤΟ 1ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΤΜΟΡΙΑ1*1000,' ΜΟΡΙΑ'
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='3') ΚΑΙ ((ΓΕΝΙΚΗΣ='2') Η (ΓΕΝΙΚΗΣ='3') Η (ΓΕΝΙΚΗΣ='4')) ΤΟΤΕ
    ΓΡΑΨΕ 'ΣΤΟ 2ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΤΜΟΡΙΑ2*1000,' ΜΟΡΙΑ'
    ΓΡΑΨΕ 'ΣΤΟ 4ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΤΜΟΡΙΑ4*1000,' ΜΟΡΙΑ'
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='3') ΚΑΙ (ΓΕΝΙΚΗΣ='2') ΤΟΤΕ
    ΓΡΑΨΕ 'ΣΤΟ 2ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΤΜΟΡΙΑ2*1000,' ΜΟΡΙΑ'
    ΓΡΑΨΕ 'ΣΤΟ 3ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΤΜΟΡΙΑ3*1000,' ΜΟΡΙΑ'
    ΓΡΑΨΕ 'ΣΤΟ 4ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΤΜΟΡΙΑ4*1000,' ΜΟΡΙΑ'
  ΑΛΛΙΩΣ_ΑΝ (ΚΑΤΕΥΘΥΝΣΗ='3') ΚΑΙ (ΓΕΝΙΚΗΣ='3') ΚΑΙ (ΕΠΙΛΟΓΗΣ='1') ΤΟΤΕ
    ΓΡΑΨΕ 'ΣΤΟ 2ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΤΜΟΡΙΑ2*1000,' ΜΟΡΙΑ'
    ΓΡΑΨΕ 'ΣΤΟ 4ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΤΜΟΡΙΑ4*1000,' ΜΟΡΙΑ'
    ΓΡΑΨΕ 'ΣΤΟ 5ο ΕΠΙΣΤΗΜΟΝΙΚΟ ΠΕΔΙΟ ΕΧΕΙΣ: ',ΤΜΟΡΙΑ5*1000,' ΜΟΡΙΑ'
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Ο ΓΕΝΙΚΟΣ ΒΑΘΜΟΣ ΠΡΟΣΒΑΣΗΣ ΕΙΝΑΙ: ',ΜΟΤ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Κορυφή
  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 25 Μάιος 2006 10:19 pm 
Σε κανενα ομως δεν υπολογιζει για 5ο πεδιο. :)


Κορυφή
  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Δευτ 12 Ιουν 2006 11:15 am 
Παράθεση:
Σε κανενα ομως δεν υπολογιζει για 5ο πεδιο. :)


το συγκεκριμενο προγραμμα το διορθωσα και πλεον υπολογιζει σωστα τα μορια σε ολα τα πεδια αναλογα με το 6ο μαθημα που επιλεγεις και αναλογα την κατευθυνση που επελεξες.

φιλικα γιωργος

charlos87@yahoo.gr


Κορυφή
  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τρί 09 Ιαν 2007 03:36 pm 
Και για να φύγουμε λίγο από από τη λογική "δουλεύει, άρα οκ", θα προτείνω τη λογική "Εντάξει, δουλεύει. Μήπως, όμως, μπορεί να λυθεί και πιο γρήγορα;"

Αυτό που κάνετε στα προγράμματά σας είναι να έχετε 3 φορές τον ίδιο κώδικα με μοναδική αλλαγή τα ονόματα των μεταβλητών και τα μηνύματα προς τον χρήστη.

Μπορεί κάποιος να δώσει ένα πρόγραμμα με την ίδια εκφώνηση με την εξής αλλαγή; Να μην υπάρχει ο ίδιος κώδικας τρεις φορές (μία για κάθε κατεύθυνση), αλλά μόνο μία φορά. Τα μηνύματα προς τον χρήστη πρέπει να παραμείνουν ίδια.


Κορυφή
  
 
 Θέμα δημοσίευσης:
ΔημοσίευσηΔημοσιεύτηκε: Τρί 03 Ιούλ 2007 06:51 pm 
Χωρίς σύνδεση

Εγγραφή: Τρί 03 Ιούλ 2007 06:21 pm
Δημοσιεύσεις: 4
Τοποθεσία: Χανιά, προσεχώς Αθήνα
Το παρακάτω είναι η δική μου (έστω και καθυστερημένη :roll: ) προσπάθεια για τον υπολογισμό μορίων των πανελλαδικών, όλων των κατευθύνσεων & των επιστημονικών πεδίων με τη χρήση όμως συναρτήσεων & διαδικασιών.

Επειδή είναι η πρώτη μου επαφή με τη Γλωσσομάθεια, συγχωρέστε τα όποια λάθη (αν και λειτουργεί σωστά νομίζω). :wink:


Syntax: [ Download ] [ Hide ]
ΠΡΟΓΡΑΜΜΑ ΥΠΟΛΟΓΙΣΜΟΣ_ΜΟΡΙΩΝ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ονομα, επων, κατ, μαθ_επιλ, ΜΑΘ[7], ΑΟΘ,ΣΩΣΤΑ
  ΑΚΕΡΑΙΕΣ: i
  ΠΡΑΓΜΑΤΙΚΕΣ:ΒΑΘ[7],ΠΡΟΦ[7],Χ,Υ
ΑΡΧΗ
  ΓΡΑΨΕ '################### ΕΝΑΡΞΗ ########################'
  ΓΡΑΨΕ
  ΓΡΑΨΕ '> Δώσε όνομα:'
  ΔΙΑΒΑΣΕ ονομα
  ΓΡΑΨΕ '> Δώσε επώνυμο:'
  ΔΙΑΒΑΣΕ επων
  γράψε '> Δώσε κατεύθυνση (ΘΕΤ=θετική, ΘΕΩΡ=θεωρητική, ΤΕΧΝ1=τεχν1, ΤΕΧΝ2=τεχν2):'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    διάβασε κατ
  ΜΕΧΡΙΣ_ΟΤΟΥ κατ='ΘΕΤ' Ή κατ='ΘΕΩΡ' Ή κατ='ΤΕΧΝ1' Ή κατ='ΤΕΧΝ2'
  γράψε '> Δώσε μάθημα επιλογής (ΜΑΘ/ΤΙΚΑ, ΒΙΟΛΟΓΙΑ, ΦΥΣΙΚΗ, ΙΣΤΟΡΙΑ):'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    διάβασε μαθ_επιλ
  ΜΕΧΡΙΣ_ΟΤΟΥ μαθ_επιλ='ΜΑΘ/ΤΙΚΑ' Ή μαθ_επιλ='ΒΙΟΛΟΓΙΑ' Ή μαθ_επιλ='ΙΣΤΟΡΙΑ' Ή μαθ_επιλ='ΦΥΣΙΚΗ'
  γράψε 'Εξετάστηκες πανελλαδικά στις ΑΟΘ [ΝΑΙ/ΟΧΙ]?'
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ ΑΟΘ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΑΟΘ='ΝΑΙ' Ή ΑΟΘ='ΟΧΙ'
  ΓΡΑΨΕ
  ΜΑΘ[1] <-- 'ΕΚΘΕΣΗ'
  ΜΑΘ[2] <-- μαθ_επιλ
  Αν κατ='ΘΕΤ' ή κατ='ΤΕΧΝ1' ή κατ='ΤΕΧΝ2' τότε
    ΜΑΘ[3] <-- 'ΜΑΘ/ΤΙΚΑ ΚΑΤ'
    ΜΑΘ[4] <-- 'ΦΥΣΙΚΗ ΚΑΤ'
    ΑΝ κατ='ΘΕΤ' τότε
      ΜΑΘ[5] <-- 'ΧΗΜΕΙΑ'
      ΜΑΘ[6] <-- 'ΒΙΟΛΟΓΙΑ ΚΑΤ'
    ΑΛΛΙΩΣ_ΑΝ κατ='ΤΕΧΝ1' τότε
      ΜΑΘ[5] <-- 'ΑΕΠΠ'
      ΜΑΘ[6] <-- 'ΑΟΔΕ'
    ΑΛΛΙΩΣ
      ΜΑΘ[5] <-- 'ΧΗΜΕΙΑ-ΒΙΟΧΗΜΕΙΑ'
      ΜΑΘ[6] <-- 'ΗΛΕΚΤΡΟΛΟΓΙΑ'
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    ΜΑΘ[3] <-- 'ΑΡΧΑΙΑ'
    ΜΑΘ[4] <-- 'ΙΣΤΟΡΙΑ'
    ΜΑΘ[5] <-- 'ΛΑΤΙΝΙΚΑ'
    ΜΑΘ[6] <-- 'ΛΟΓΟΤΕΧΝΙΑ'
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΑΟΘ='ΝΑΙ' ΤΟΤΕ
    ΜΑΘ[7] <-- 'ΑΟΘ'
  ΑΛΛΙΩΣ
    ΜΑΘ[7] <-- '---'
  ΤΕΛΟΣ_ΑΝ
  ΚΑΛΕΣΕ ΠΡΟΦΟΡΙΚΟΙ(ΠΡΟΦ,ΜΑΘ,ΑΟΘ)
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΥΣ ΒΑΘΜΟΥΣ ΤΩΝ ΠΑΝΕΛΛΗΝΙΩΝ(ΚΛΙΜΑΚΑ 0-20) ΣΤΑ ΑΝΤΙΣΤΟΙΧΑ ΜΑΘΗΜΑΤΑ!'
    ΓΡΑΨΕ
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 7
      ΑΝ i<>7 ΤΟΤΕ
        ΓΡΑΨΕ i,'.', ΜΑΘ[i]
        ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ΔΙΑΒΑΣΕ ΒΑΘ[i]
        ΜΕΧΡΙΣ_ΟΤΟΥ ΒΑΘ[i]>=0 ΚΑΙ ΒΑΘ[i]<=20
      ΑΛΛΙΩΣ
        ΑΝ ΑΟΘ='ΝΑΙ' ΤΟΤΕ
          ΓΡΑΨΕ '7. ΑΟΘ: '
          ΔΙΑΒΑΣΕ ΒΑΘ[7]
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
      Χ <-- ΠΡΟΦ[i]
      Υ <-- ΒΑΘ[i]
      ΠΡΟΦ[i] <-- ΠΡΟΣΑΡΜΟΓΗ(Χ,Υ)
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΑΟΘ='ΝΑΙ' ΤΟΤΕ
      Χ <-- ΠΡΟΦ[7]
      Υ <-- ΒΑΘ[7]
      ΠΡΟΦ[7] <-- ΠΡΟΣΑΡΜΟΓΗ(Χ,Υ)
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ
    ΓΡΑΨΕ '** ΕΠΙΒΕΒΑΙΩΣΗ ΣΤΟΙΧΕΙΩΝ **'
    ΓΡΑΨΕ
    ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
      ΓΡΑΨΕ ΜΑΘ[i], '->', ΒΑΘ[i]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΝ ΑΟΘ='ΝΑΙ' ΤΟΤΕ
      ΓΡΑΨΕ ΜΑΘ[7], '->', ΒΑΘ[7]
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ
    ΓΡΑΨΕ 'ΕΙΝΑΙ ΣΩΣΤΑ ΤΑ ΠΑΡΑΠΑΝΩ ΣΤΟΙΧΕΙΑ (ΝΑΙ/ΟΧΙ)?'
    ΔΙΑΒΑΣΕ ΣΩΣΤΑ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΣΩΣΤΑ='ΝΑΙ'
  !
  ΓΡΑΨΕ '############## ΑΠΟΤΕΛΕΣΜΑΤΑ #################'
  ΓΡΑΨΕ
  ΓΡΑΨΕ 'ΟΝΟΜΑ: ', ονομα
  ΓΡΑΨΕ 'ΕΠΩΝΥΜΟ: ', επων
  ΓΡΑΨΕ 'ΚΑΤΕΥΘΥΝΣΗ: ', κατ
  ΓΡΑΨΕ 'ΜΑΘΗΜΑ ΕΠΙΛΟΓΗΣ ΓΠ: ', μαθ_επιλ
  ΚΑΛΕΣΕ ΥΠΟΛ_ΜΟΡΙΩΝ(κατ,ΜΑΘ,ΒΑΘ,ΠΡΟΦ,ΑΟΘ)
  γράψε '############## ΤΕΛΟΣ ####################'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

!ΣΥΝΑΡΤΗΣΗ ΠΡΟΣΑΡΜΟΓΗ - προσαρμογή προφορικού βαθμού στο γραπτό
ΣΥΝΑΡΤΗΣΗ ΠΡΟΣΑΡΜΟΓΗ(Π,Γ):ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:Π,Γ
ΑΡΧΗ
  ΑΝ Π>Γ ΚΑΙ (Π-Γ)>2 ΤΟΤΕ
    ΠΡΟΣΑΡΜΟΓΗ <-- Γ+2
  ΑΛΛΙΩΣ_ΑΝ Π<Γ ΚΑΙ (Γ-Π)>2 ΤΟΤΕ
    ΠΡΟΣΑΡΜΟΓΗ <-- Γ-2
  ΑΛΛΙΩΣ
    ΠΡΟΣΑΡΜΟΓΗ <-- Π
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ




!ΔΙΑΔΙΚΑΣΙΑ ΠΡΟΦΟΡΙΚΟΙ - καταχώρηση από το χρήστη τον προφορικών του βαθμών
ΔΙΑΔΙΚΑΣΙΑ ΠΡΟΦΟΡΙΚΟΙ(Α,ΜΑΘ,ΑΟΘ)
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Α[7], Β[7,2]
  ΧΑΡΑΚΤΗΡΕΣ: ΜΑΘ[7], ΑΟΘ
  ΑΚΕΡΑΙΕΣ: Ι, J
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 7
    Αν Ι<>7 τότε
      ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 2
        ΓΡΑΨΕ 'ΔΩΣΕ ΠΡΟΦΟΡΙΚΟ ΒΑΘΜΟ',J,'ΤΕΤΡΑΜΗΝΟΥ ΣΤΟ ΜΑΘΗΜΑ',ΜΑΘ[Ι]
        ΔΙΑΒΑΣΕ Β[Ι,J]
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      Α[Ι] <-- (Β[Ι,1]+Β[Ι,2])/2
    ΑΛΛΙΩΣ
      ΑΝ ΑΟΘ='ΝΑΙ' ΤΟΤΕ
        ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 2
          ΓΡΑΨΕ 'ΔΩΣΕ ΠΡΟΦΟΡΙΚΟ ΒΑΘΜΟ',J,'ΤΕΤΡΑΜΗΝΟΥ ΣΤΙΣ ΑΟΘ'
          ΔΙΑΒΑΣΕ Β[Ι,J]
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        Α[7] <-- (Β[7,1]+Β[7,2])/2
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

!ΔΙΑΔΙΚΑΣΙΑ ΥΠΟΛΟΓΙΣΜΟΣ ΜΟΡΙΩΝ
!
!
ΔΙΑΔΙΚΑΣΙΑ ΥΠΟΛ_ΜΟΡΙΩΝ(ΚΑΤ,ΜΑΘ,ΒΑΘ,ΠΡΟΦ,ΑΟΘ)
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ:ΚΑΤ,ΜΑΘ[7],ΑΟΘ
  ΠΡΑΓΜΑΤΙΚΕΣ:ΒΑΘ[7],ΠΡΟΦ[7],SUM,ΒΠ,ΒΠ_ΜΑΘ[7],ΜΟΡΙΑ_1,ΜΟΡΙΑ_2,ΜΟΡΙΑ_3,ΜΟΡΙΑ_4,ΜΟΡΙΑ_5
  ΑΚΕΡΑΙΕΣ: i
ΑΡΧΗ
  SUM <-- 0
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 6
    ΒΠ_ΜΑΘ[i] <-- (0.3*ΠΡΟΦ[i]+0.7*ΒΑΘ[i])
    SUM <-- SUM+ΒΠ_ΜΑΘ[i]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΒΠ <-- SUM/6
  ΑΝ ΑΟΘ='ΝΑΙ' ΤΟΤΕ
    ΒΠ_ΜΑΘ[7] <-- (0.3*ΠΡΟΦ[7]+0.7*ΒΑΘ[7])
    SUM <-- SUM+ΒΠ_ΜΑΘ[7]
    ΒΠ <-- SUM/7
  ΤΕΛΟΣ_ΑΝ
  ΑΝ ΚΑΤ='ΘΕΩΡ' ΤΟΤΕ
    ΜΟΡΙΑ_1 <-- ΒΠ*800+ΒΠ_ΜΑΘ[3]*130+ΒΠ_ΜΑΘ[4]*70
    ΑΝ ΜΑΘ[2]='ΜΑΘ/ΤΙΚΑ' ΤΟΤΕ
      ΜΟΡΙΑ_2 <-- ΒΠ*800+ΒΠ_ΜΑΘ[1]*40+ΒΠ_ΜΑΘ[2]*90
      ΜΟΡΙΑ_4 <-- ΜΟΡΙΑ_2
      ΑΝ ΑΟΘ='ΝΑΙ' ΤΟΤΕ
        ΜΟΡΙΑ_5 <-- ΒΠ*800+ΒΠ_ΜΑΘ[7]*130+ΒΠ_ΜΑΘ[2]*70
      ΑΛΛΙΩΣ
        ΜΟΡΙΑ_5 <-- 1*(-1)
      ΤΕΛΟΣ_ΑΝ
      ΜΟΡΙΑ_3 <-- 1*(-1)
    ΑΛΛΙΩΣ_ΑΝ ΜΑΘ[2]='ΒΙΟΛΟΓΙΑ' ΤΟΤΕ
      ΜΟΡΙΑ_3 <-- ΒΠ*800+ΒΠ_ΜΑΘ[2]*90+ΒΠ_ΜΑΘ[1]*40
      ΜΟΡΙΑ_2 <-- 1*(-1)
      ΜΟΡΙΑ_4 <-- ΜΟΡΙΑ_2
      ΜΟΡΙΑ_5 <-- ΜΟΡΙΑ_2
    ΑΛΛΙΩΣ
      ΜΟΡΙΑ_2 <-- 1*(-1)
      ΜΟΡΙΑ_4 <-- ΜΟΡΙΑ_2
      ΜΟΡΙΑ_5 <-- ΜΟΡΙΑ_2
      ΜΟΡΙΑ_5 <-- ΜΟΡΙΑ_2
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ ΚΑΤ='ΘΕΤ' ΤΟΤΕ
    ΜΟΡΙΑ_2 <-- ΒΠ*800+ΒΠ_ΜΑΘ[3]*130+ΒΠ_ΜΑΘ[4]*70
    ΜΟΡΙΑ_4 <-- ΒΠ*800+ΒΠ_ΜΑΘ[3]*130+ΒΠ_ΜΑΘ[4]*70
    ΜΟΡΙΑ_3 <-- ΒΠ*800+ΒΠ_ΜΑΘ[6]*130+ΒΠ_ΜΑΘ[5]*70
    ΑΝ ΜΑΘ[2]='ΜΑΘ/ΤΙΚΑ' ΤΟΤΕ
      ΜΟΡΙΑ_1 <-- 1*(-1)
      ΑΝ ΑΟΘ='ΝΑΙ' ΤΟΤΕ
        ΜΟΡΙΑ_5 <-- ΒΠ*800+ΒΠ_ΜΑΘ[7]*130+ΒΠ_ΜΑΘ[2]*70
      ΑΛΛΙΩΣ
        ΜΟΡΙΑ_5 <-- 1*(-1)
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ_ΑΝ ΜΑΘ[2]='ΙΣΤΟΡΙΑ' ΤΟΤΕ
      ΜΟΡΙΑ_1 <-- ΒΠ*800+ΒΠ_ΜΑΘ[2]*90+ΒΠ_ΜΑΘ[1]*40
      ΜΟΡΙΑ_5 <-- 1*(-1)
    ΑΛΛΙΩΣ
      ΜΟΡΙΑ_5 <-- 1*(-1)
      ΜΟΡΙΑ_1 <-- 1*(-1)
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    ΜΟΡΙΑ_2 <-- ΒΠ*800+ΒΠ_ΜΑΘ[3]*130+ΒΠ_ΜΑΘ[4]*70
    ΜΟΡΙΑ_4 <-- ΒΠ*800+ΒΠ_ΜΑΘ[3]*130+ΒΠ_ΜΑΘ[4]*70
    ΑΝ ΜΑΘ[2]='ΜΑΘ/ΤΙΚΑ' ΤΟΤΕ
      ΑΝ ΑΟΘ ='ΝΑΙ' ΤΟΤΕ
        ΜΟΡΙΑ_5 <-- ΒΠ*800+ΒΠ_ΜΑΘ[7]*130+ΒΠ_ΜΑΘ[2]*70
      ΑΛΛΙΩΣ
        ΜΟΡΙΑ_5 <-- 1*(-1)
      ΤΕΛΟΣ_ΑΝ
      ΜΟΡΙΑ_1 <-- 1*(-1)
      ΜΟΡΙΑ_3 <-- 1*(-1)
    ΑΛΛΙΩΣ_ΑΝ ΜΑΘ[2]='ΒΙΟΛΟΓΙΑ' ΤΟΤΕ
      ΜΟΡΙΑ_5 <-- 1*(-1)
      ΜΟΡΙΑ_1 <-- 1*(-1)
      ΜΟΡΙΑ_3 <-- ΒΠ*800+ΒΠ_ΜΑΘ[2]*90+ΒΠ_ΜΑΘ[1]*40
    ΑΛΛΙΩΣ_ΑΝ ΜΑΘ[2]='ΙΣΤΟΡΙΑ' ΤΟΤΕ
      ΜΟΡΙΑ_1 <-- ΒΠ*800+ΒΠ_ΜΑΘ[2]*90+ΒΠ_ΜΑΘ[1]*40
      ΜΟΡΙΑ_5 <-- 1*(-1)
      ΜΟΡΙΑ_3 <-- ΜΟΡΙΑ_5
    ΑΛΛΙΩΣ
      ΜΟΡΙΑ_5 <-- 1*(-1)
      ΜΟΡΙΑ_1 <-- 1*(-1)
      ΜΟΡΙΑ_3 <-- ΜΟΡΙΑ_5
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ
!
!ΕΜΦΑΝΙΣΗ
  ΓΡΑΨΕ
  ΓΡΑΨΕ '#####################'
  ΓΡΑΨΕ '* 1ο ΠΕΔΙΟ: ',ΜΟΡΙΑ_1
  ΓΡΑΨΕ '* 2ο ΠΕΔΙΟ: ',ΜΟΡΙΑ_2
  ΓΡΑΨΕ '* 3ο ΠΕΔΙΟ: ',ΜΟΡΙΑ_3
  ΓΡΑΨΕ '* 4ο ΠΕΔΙΟ: ',ΜΟΡΙΑ_4
  ΓΡΑΨΕ '* 5ο ΠΕΔΙΟ: ',ΜΟΡΙΑ_5
  ΓΡΑΨΕ '#####################'
  ΓΡΑΨΕ
  ΓΡΑΨΕ '!Σημείωση!: όπου υπάρχει ο βαθμός "-1" σημαίνει ότι ο υποψήφιος'
  ΓΡΑΨΕ 'δε δικαιούται να δηλώσει σχολές από αυτό το πεδίο.'
  γράψε
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

_________________
http://misparrow.blogspot.com


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Τρί 25 Δεκ 2007 11:27 am 
Χωρίς σύνδεση

Εγγραφή: Σάβ 22 Δεκ 2007 08:10 pm
Δημοσιεύσεις: 1
manthos_k έγραψε:
ας:

sigoura doulei kanonika gt nomizw prepei na exei apoklish sta apotelesmata...gia deste to ligo... :wink:


Κορυφή
 Προφίλ  
 
ΔημοσίευσηΔημοσιεύτηκε: Πέμ 10 Ιαν 2008 12:09 am 
Χωρίς σύνδεση

Εγγραφή: Δευτ 22 Οκτ 2007 12:46 pm
Δημοσιεύσεις: 15
το πρόγραμμα υπάρχει εδώ και αρκετό καιρό έτοιμο...
http://www.spinet.gr/glossomatheia/programs/viewtopic.php?f=11&t=590


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση ανά  
Δημιουργία νέου θέματος Απαντήστε στο θέμα  [ 9 Δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μέλη σε σύνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επισυνάπτετε αρχεία σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Προβολές: